PowerStore: Unable to Configure ESMTP Mail Servers

Summary: Attempting to configure ESMTP mail fails with the error message: "Failed SMTP configuration test, Reason: Could not connect to host, port: smtp.office356.com, 587; timeout 25000" (User Correctable) ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When sending a test email or SMTP notification, this may fail if these conditions are met:

  • The STARTTLS or SMTP-AUTH extensions are enabled on the SMTP server
  • The PowerStoreOS version is 4.1 or earlier

 

The following error may be reported in the Control Path logs when configuring a PowerStore appliance to use an ESMTP server (for example, Outlook365 or other cloud-based mail services):

Mar 10 15:19:02 APM01210604693-A control-path[12519]: 2021-03-10 15:19:02.689 [] [ERROR] [com.emc.bedrock.command.CommandServiceVerticle|vert.x-eventloop-thread-3] [1aad1cb7-bc69-4aa1-a209-7947a0c32f68] Received a response to com.emc.cyclone.contexts.networkconfiguration.domain.commands.SmtpTestCommand parent id: , instance id: 0, start time: 2021-03-10T15:19:02.313Z, Command initialized by REST request d1874425-9930-4015-8d2e-58878b0c55c0
Failed SMTP config test, Reason: Couldn't connect to host, port: smtp.office356.com, 587; timeout 25000

Cause

PowerStoreOS version 4.1 and earlier do not support specific SMTP extensions that are required with ESMTP servers.

 

 

Resolution

PowerStoreOS 4.1 or earlier: Disable the STARTTLS and SMTP-AUTH extension settings on the SMTP server. (Use a Basic SMTP server)
 
PowerStoreOS 4.2 or higher: Verify the SMTP server authentication settings on both the PowerStore and the SMTP server application. In addition, verify the email relay settings and any environmental, network, or firewall-related settings.

Affected Products

PowerStore
Article Properties
Article Number: 000184400
Article Type: Solution
Last Modified: 03 Dec 2025
Version:  6
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