NetWorker: Client creation wizard fails at the end with error - host is not valid
Summary: Client creation wizard fails with host is not valid error due to name resolution issues.
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Symptoms
When creating a new client using the NetWorker Management Console (NMC) Client Creation Wizard, client creation fails with the error host is not valid.
- Start the Client Creation Wizard.
- Follow the steps to create a new client.
- At the end when clicking create, creation fails with
Invalid hosterror message. - Fix name resolution by creating a Pointer Record (PTR) record in the Domain Name System (DNS) server.
- Repeated the above steps but still failed to create the client.
- Restart the NetWorker services on the NetWorker server.
- Repeat the above steps to create the client using the Wizard and the creation succeeds.
Cause
The absence of a PTR record in the DNS host entry triggers the issue, leading to name resolution failure.
If the issue persists after correcting the PTR record in DNS, the NetWorker DNS cache contains stale entries which must be cleared.
Resolution
Steps to resolve:
- Add or change the PTR entry in the DNS server.
- If the problem persists, then NMC is using cached DNS lookups in NetWorker.
-
- Either restart the NetWorker services on the NetWorker server.
- Or clear the NetWorker DNS lookup cache explicitly using:
dbgcommand -p <gstd PID> FlushDnsCache
Affected Products
Data Backup & Protection Software, NetWorkerArticle Properties
Article Number: 000056655
Article Type: Solution
Last Modified: 22 Aug 2025
Version: 5
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