NVE: OS rollup stops "Update NRE(NetWorker Runtime Environment) (10 of 18) Failed"

Summary: During a NetWorker Virtual Edition (NVE) OS Rollup, the installation process stops reporting "Update NRE(NetWorker Runtime Environment) (10 of 18) Failed"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NVE OS rollup stops with the following shown in the NVE Installation Manager:
NRE upgrade failed

The NVE /data01/avamar/repo/temp/*/tmp/err.log reports:

nve:~ # cat /data01/avamar/repo/temp/*/tmp/err.log
YYYY-MM-DD HH:MM:SS (-TZ) 47055569025700 ERROR: "mkdir -p /usr/local/avamar/src/SLES_64/osrollup-backups/ && cp -f /opt/nre/java/latest/lib/security/cacerts /usr/local/avamar/src/SLES_64/osrollup-backups/", exit status=1 (error)
YYYY-MM-DD HH:MM:SS (-TZ) 47055569025700 ERROR: Failed to backup cacerts - operation failed

Cause

The OS rollup is attempting to backup the cacerts file from the path /opt/nre/java/latest/lib/security/cacerts.

The /opt/nre/java/latest/ symbolic link has been removed on the NVE.

Either this symbolic link was manually deleted, or the NetWorker Runtime Environment was manually upgraded and /opt/nre/nreconfig.sh was not run after the upgrade. This script is required after manually upgrading NRE to re-create the /opt/nre/java/latest symbolic link pointing to the new Java Runtime Environment (JRE) folder.

Resolution

1. Open an SSH session to the NVE and log in as admin
2. Switch to root: sudo su -
3. Confirm the current NRE "jre" folder path:

ls -l /opt/nre/java

4. Re-create the /opt/nre/java/latest symbolic link: /opt/nre/nreconfig.sh

nve:~ # /opt/nre/nreconfig.sh

Creating the installation log in /opt/nre/logs/install.log.

Performing initialization. Please wait...

NRE configuration completed

OR
ln -s /opt/nre/java/jre#.#.#_### /opt/nre/java/latest
NOTE: Replace the jre folder with the jre folder returned from `ls -l /opt/nre/java` if multiple jre folders are shown, use the latest version.

5. Return to the NVE web user interface.
6. Click the Call Support option, then click Issue Resolved, continuing the installation.

retry task

7. Monitor the installation for completion. The rollup may restart the NVE or make the web user interface temporarily unavailable. Refresh the web interface periodically.

You can also monitor the workflow log on the NVE from a shell session:

sudo tail -f /data01/avamar/repo/temp/*/tmp/workflow.log

 

Additional Information

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000226864
Article Type: Solution
Last Modified: 24 Jun 2025
Version:  3
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