RecoverPoint: Customer cannot view cluster settings through boxmgmt menu

Summary: Unable to view cluster settings through boxmgmt menu.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  1. Issue (impact on customer):
    Customer cannot view cluster settings through boxmgmt menu.
     
  2. Impacted Configuration & Settings [Replication Mode,Splitter Type,Compression,CDP/CLR/Multi,FC/IP/iSCSI, Policies etc.]:
    RPA configured an empty secondary NTP server
     
  3. Impact on RP: Boxmgmt functioning - cannot view cluster settings.
     
  4. Affected versions: 5.1

Cause

Empty secondary NTP server configured (probably user enter space in second empty NTP server box) leads to string parsing failure.

Resolution

Fixed at:
This symptom - 5.1.1
The prevention of send space as NTP server from DGUI - 5.2

Workaround:
Configure NTP servers again using boxmgmt.

Additional Information

Symptoms found in the logs:
In cluster logic logs:
 ntpServers=[****, ]
 

Or in Installation server logs:


secondaryNtpServersSet=[]

When selecting View Settings for a cluster in boxmgmt menu, it returns "Failed to execute step".

In /home/kos/installationLogs/cli.log you see:

06/09/2017 19:09:17,410: ERROR [main:com.kashya.installation.client.ui.MenuManager] Exception in handling UIStep

java.lang.ArrayIndexOutOfBoundsException: 0

        at com.kashya.installation.client.ui.console.table.Tables.addNTPRows(Tables.java:75)

Affected Products

RecoverPoint

Products

RecoverPoint
Article Properties
Article Number: 000050413
Article Type: Solution
Last Modified: 20 Aug 2025
Version:  5
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