Avamar: SQL backup operations randomly stop responding leaving avsql and avtar processes stuck
Summary: Randomly during Avamar backup a customer sees backup stopped responding requiring manual intervention.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Randomly during Avamar backup a customer sees backup stopped responding requiring manual intervention.
This behavior is mostly seen during backups of large Databases and multi-streaming enabled.
During the stop responding, the data processing stops until the Virtual Backup Device Interface (VDI) connection times out as per "vditransfertimeoutsecs" settings. In customer case, it was set to 3 hrs and time-out for avsql_t3 thread in the excerpt below:
This behavior is mostly seen during backups of large Databases and multi-streaming enabled.
<flag type="pulldown" pidnum="3006" value="4" name="max-parallel" /> <flag type="pulldown" pidnum="3006" value="1024" name="min-snapup-size" />The same server backup will run successfully next time and may not exhibit these stop responding symptoms again for a while.
During the stop responding, the data processing stops until the Virtual Backup Device Interface (VDI) connection times out as per "vditransfertimeoutsecs" settings. In customer case, it was set to 3 hrs and time-out for avsql_t3 thread in the excerpt below:
2019-11-05 19:43:27 avsql Info <42988>: VDC_Complete is not supported by VDI. 2019-11-05 19:43:27 avsql Error <6478>: VDS::Getconfig failed with 'The api was waiting and the timeout interval had elapsed' 2019-11-05 19:43:27 avsql Error <6479>: Timed out. Was Microsoft SQLServer running? 2019/11/06-00:43:27.75200 [avsql_t3] Canceling avtar sub-process ...Here the avsql_t3 thread is stuck after calling GetConfiguration of SQL VDI function.
Cause
There is a software glitch in the GetConfiguration() component of the Microsoft SQL VDI API/function that Avamar Plugin uses.
Resolution
The software glitch is under investigation by Avamar and Microsoft developers.
Contact Avamar support for the latest update.
Contact Avamar support for the latest update.
Affected Products
AvamarArticle Properties
Article Number: 000068644
Article Type: Solution
Last Modified: 05 Sep 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.