PowerStore: SupportAssist fails to enable in Gateway Connect mode
Summary: Trying to enable SupportAssist fails when attempted from PowerStore Manager (UI) in Gateway Connect mode (over external gateway).
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Possible errors seen in PowerStore Manager:
| Error Code | Error Message |
| 0xE0101001000C | SupportAssist: The system encountered unexpected backend errors. |
| 0x00d00302 | Remote support of appliance was not enabled because it failed to connect to the SRS Gateway with error: Failed to enable SupportAssist connectivity on this appliance. Error Response: Service Unavailable |
Cause
There are many possible causes for these types or errors, such as:
- Problems with the Secure Remote Services (SRS) or SupportAssist (SAE) or Secure Connect Gateway (SCG) server or VM.
- Firewall issues blocking required ports between the PowerStore and the gateway.
Resolution
The troubleshooting process should include:
- Confirming that your Secure Remote Services (SRS), SupportAssist Enterprise (SAE), or Secure Connect Gateway (SCG) version is supported and compatible with PowerStore (details available in the Dell EMC PowerStore Planning Guide).
- Ensuring that the required port is open between the PowerStore and the Secure Remote Services (SRS) Gateway Server (port 9443).
- Restarting the SRS gateway server, and then trying to setup the PowerStore from PowerStore Manager or PowerStore CLI again.
A full redeploy of the SRS gateway server may be required in some instances where, for example, an update between major SRS gateway versions may have resulted in corruption of the virtual machine.
Additional Information
Setting up SupportAssist in PowerStore is only supported when configured from the PowerStore side (UI or CLI).
Setting up SupportAssist from the gateway server side or servicelink is not supported. This may appear to work but may not function as expected (example, the system may fail to dial home).
Setting up SupportAssist from the gateway server side or servicelink is not supported. This may appear to work but may not function as expected (example, the system may fail to dial home).
Affected Products
PowerStoreArticle Properties
Article Number: 000130187
Article Type: Solution
Last Modified: 19 Dec 2022
Version: 10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.