Avamar: Windows File system Plugin missing from the backup or restore tab

Summary: Avamar Client: Windows File system Plugin missing from the backup/restore tab

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Under the backup and restore tab of Avamar administrator, we see that the Filesystem plug-in is missing and we are able to view only the VSS. Review of "C:\Program Files\avs\var\avagent.log shows a warning message that appears to be plug-in (avtar) and agent are different versions and only VSS plug-in being registered.
 
avagent Info : Reading pin file C:\Program Files\avs\bin\windows.pin
avagent Info : Finished READING xml file - starting parse avagent Info : Checking version of plug-in 'Windows', executable name 'avtar' (mode:ctl)
avagent Info : Plug-in version 19.2.100-155_HF325722 found for Windows plug-in
avagent Warning : Plug-in (avtar) and agent are different versions (19.2.100-155_HF325722 and 19.1.100-38).

****** Current MCS name 'avamarserver.com' ******
avagent Info : Registration of client /clients/test.dell.com with MCS avamarserver,com:28001 successful.
avagent Info : Registration of plugin 3015 VSS successful.
avagent Info : Registration of plugin 3023 update successful.
avagent Info : Registration of plugin 3015 VSS successful.
avagent Info : Registration of plugin 3023 update successful.
avagent Info : Registration of client and plugins complete.



Also, the client icon from system tray indicates a different plug-in 

different version of Windows and VSS

Cause

NOTE: This can happen in any version if the uninstallation of the previous plugins is done incorrectly.
In this case customer had previously installed 19.2 with HF325722 (avtar.exe) and decided to downgrade back to 19.1.
When the 19.1 plugin was reinstalled the hotfix binary was not removed due to which only the VSS plugin was visible on the Avamar.

Resolution


1. Before you decide to upgrade or downgrade from the existing plugins, please make sure you uninstall it completely .
2. Navigate to control panel, select the application (EMC Avamar for Windows) and click uninstall.

Click uninstall

3. Once the plugin is uninstalled you can install the new plugin.

 
 

Affected Products

Avamar Client, Microsoft Windows 2012 Server
Article Properties
Article Number: 000201404
Article Type: Solution
Last Modified: 01 Jun 2023
Version:  2
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