NetWorker: Po použití příkazu nsrdr nelze zobrazit ID klienta pro všechny klienty

Summary: Po použití příkazu nsrdr k migraci nebo obnovení serveru NetWorker již není atribut ID klienta pro všechny klienty viditelný.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Server NetWorker byl migrován na nového hostitele nebo byl obnoven ze zálohy bootstrap pomocí příkazu nsrdr. Po obnovení po havárii chybí v zobrazení Konzole NMC (NetWorker Management Console) hodnoty ID klienta. Namísto názvu serveru NetWorker se atribut hostname zobrazuje také jako prázdný:
 
Zobrazení konzole NetWorker Management Console
Obrázek 1: Zobrazení konzole NetWorker Management Console
 
Vlastnosti klienta
Obrázek 2: Vlastnosti klienta

Id klientů jsou v databázi médií k dispozici i pro nové zálohy a lze je zkontrolovat pomocí následujícího příkazu:
mminfo
Zkontrolujte ID klienta pomocí příkazu mminfo.
Obrázek 3: Zkontrolujte ID klienta pomocí příkazu mminfo.
 
Při kontrole pomocí níže uvedených možností chybí v databázi zdrojů ID klienta: 
nsradmin
Zkontrolujte ID klienta pomocí nástroje nsradmin.
Obrázek 4: Zkontrolujte ID klienta pomocí nástroje nsradmin.

V protokolu démon serveru NetWorker se během spouštění služby zaznamenávají následující zprávy:
DD/MM/YYYY HH:MM:SS  1 5 0 11092 11088 0 networkersrv01.demo.local nsrd NSR notice The fast system restart of NetWorker is enabled. DNS cache will not be populated and RAP check of the clients will be skipped. 
DD/MM/YYYY HH:MM:SS  1 5 0 11092 11088 0 networkersrv01.demo.local nsrd NSR notice Skipping populating DNS cache as disaster recovery is in progress ... 

Cause

nsr_disaster_recovery_mode soubor se nachází v adresáři /nsr/debug. Tento soubor je vytvořen jako součást postupu nsrdr. Povoluje restartování systému souborů serveru NetWorker zakázáním vyhledávání DNS, což vede k tomu, že ID klienta během spouštění služby chybí nebo nejsou načtena do databáze zdrojů.

Při normálních operacích DR by měl být tento soubor na konci procesu spouštění odstraněn. V případě selhání nebo pokud se příkaz nsrdr nedokončí správně, může být tento soubor ponechán v adresáři /nsr/debug, který vyžaduje ruční odebrání.

Resolution

Chcete-li zakázat režim DR nebo rychlý restart systému, když nejsou spuštěny žádné aktivity netWorker, proveďte následující kroky:
  1. Zastavte služby NetWorker:
Windows:    net stop nsrd
Linux:      systemctl stop networker
  1. Přejmenujte nebo odstraňte soubor "nsr_disaster_recovery_mode" z adresáře /nsr/debug.
  2. Restartujte Služby NetWorker:
Windows:    net start nsrd
Linux:      systemctl start networker

Additional Information

Affected Products

NetWorker
Article Properties
Article Number: 000218693
Article Type: Solution
Last Modified: 31 Oct 2023
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.