NetWorker: Client-IDs für alle Clients können nach der Verwendung von nsrdr nicht angezeigt werden

Summary: Nach der Verwendung von nsrdr zum Migrieren oder Wiederherstellen des NetWorker-Servers ist das Client-ID-Attribut nicht mehr für alle Clients sichtbar.

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Symptoms

Der NetWorker-Server wurde mit dem Befehl nsrdr auf einen neuen Host migriert oder aus dem Bootstrap-Backup wiederhergestellt. Nach der Disaster Recovery fehlen Client-ID-Werte in der NmC-Ansicht (NetWorker Management Console). Das Attribut hostname wird ebenfalls leer angezeigt, anstatt den NetWorker-Servernamen zu haben:
 
Ansicht
Abbildung 1: Ansicht "NetWorker Management Console"
 
Clienteigenschaften
Abbildung 2: Clienteigenschaften

Client-IDs sind auch für neue Backups in der Mediendatenbank verfügbar und können mit dem folgenden Befehl überprüft werden:
mminfo
Überprüfen Sie die Client-ID mit dem Befehl mminfo.
Abbildung 3: Überprüfen Sie die Client-ID mit dem Befehl mminfo.
 
Client-IDs fehlen in der Ressourcendatenbank, wenn sie mithilfe der folgenden Optionen geprüft werden: 
nsradmin
Überprüfen der Client-ID mithilfe des Dienstprogramms nsradmin
Abbildung 4: Überprüfen Sie die Client-ID mithilfe des Dienstprogramms nsradmin.

Im Daemon-Protokoll des NetWorker-Servers werden die folgenden Meldungen während des Servicestarts protokolliert:
DD/MM/YYYY HH:MM:SS  1 5 0 11092 11088 0 networkersrv01.demo.local nsrd NSR notice The fast system restart of NetWorker is enabled. DNS cache will not be populated and RAP check of the clients will be skipped. 
DD/MM/YYYY HH:MM:SS  1 5 0 11092 11088 0 networkersrv01.demo.local nsrd NSR notice Skipping populating DNS cache as disaster recovery is in progress ... 

Cause

nsr_disaster_recovery_mode Datei ist im Verzeichnis /nsr/debug vorhanden. Diese Datei wird im Rahmen des nsrdr-Verfahrens erstellt. Sie ermöglicht den Neustart des NetWorker-Servers durch Deaktivieren von DNS-Suchen, was dazu führt, dass die Client-IDs während des Servicestarts fehlen oder nicht in die Ressourcendatenbank geladen werden.

Bei normalen DR-Vorgängen sollte diese Datei am Ende des Startvorgangs gelöscht werden. Falls jedoch ein Fehler auftritt oder nsrdr nicht ordnungsgemäß abgeschlossen wird, wird diese Datei möglicherweise im Verzeichnis /nsr/debug verbleiben, das eine manuelle Entfernung erfordert.

Resolution

Führen Sie die folgenden Schritte aus, um den DR-Modus oder den schnellen Systemneustart zu deaktivieren, wenn keine NetWorker-Aktivitäten ausgeführt werden:
  1. Beenden Sie die NetWorker-Services:
Windows:    net stop nsrd
Linux:      systemctl stop networker
  1. Benennen Sie die Datei "nsr_disaster_recovery_mode" aus dem Verzeichnis /nsr/debug um oder löschen Sie sie.
  2. Neu starten NetWorker-Services:
Windows:    net start nsrd
Linux:      systemctl start networker

Additional Information

Affected Products

NetWorker
Article Properties
Article Number: 000218693
Article Type: Solution
Last Modified: 31 Oct 2023
Version:  2
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