Dell Unity: Received error code "The DNS client is unable to connect to name server xx.xx.xx.xx"
Summary: Dell Unity: Received error code "The DNS client is unable to connect to name server xx.xx.xx.xx" (User Correctable)
Symptoms
The user is receiving the below error multiple times on the destination array:
The DNS client is unable to connect to name server xxx.xxx.xxx.xxx :I/O error
Cause
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When using NAS Server replication, the destination system sometimes inaccurately reported that DNS, NIS, or LDAP services were not accessible and that the fix is in version 4.2.1.9535982
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Unity OE Code (4.2.1.9535982) code is available to perform the upgrade
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An additional scenario has been identified where having CEPA configured on the source array can trigger these errors on the destination array each time replication is synced. This can be seen in all Unity OE code releases up to 5.0.2.x. The fix will be implemented in a future Unity OE release
Resolution
Workaround #1:
Suppress the DNS/LDAP/NIS alerts by applying the following parameter change on the source array:
DNS:
svc_nas -param -facility dns -modify suppressDnsStatus -value 1
NIS:
svc_nas -param -facility nis -modify suppressNisStatus -value 1
LDAP:
svc_nas -param -facility ldap -modify suppressLdapStatus -value 1
Workaround #2:
In the case where CEPA is deemed to be the contributing factor in the DNS errors on the destination NAS server, suppressing the alert does not work at this time. To mitigate the errors, configure the NAS servers on the source array to use the IP addresses for the CEPA servers. This negates the need for name resolution.
Additional Information
To confirm the issue:
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Performed: tailf /EMC/C4Core/log/c4_safe_ktrace.log | grep 'The DNS client is unable to connect to name server' and the below errors appeared:
2017/11/14-11:24:07.434651 14 7F8A96254707 sade:DNS: 1: 3:[<nas_server>] The DNS client is unable to connect to the name server xxx.xxx.xxx.xxx : I/O error 2017/11/14-11:24:07.434754 10 7F8A96254703 sade:DNS: 1: 3:[<nas_server>] The DNS client is unable to connect to the name server xxx.xxx.xxx.xxx : I/O error
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Confirmed that all the NAS servers are operating normally using:
uemcli /net/nas/server show
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Confirmed also that the NAS server interfaces are ok using
uemcli /net/nas/if show