AppSync: Error connecting to Agent post Upgrade of Agent host or AppSync

Summary: Error connecting to Agent post Upgrade of Agent host or AppSync

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Symptoms

Issues in connecting to Agent as the connectivity in the GUI turns to "Red" post Upgrades of Agent host or AppSync.
 

06-24-2025 15:41:31.023 ERROR [default task-88] [com.emc.archway.restapi.restresources.host.HostInstanceResource] [AppSync server] [] AppSync server failed to connect to agent host <UNIX_HOST> Ensure the agent host is up and reachable from the AppSync server. If this is a Windows agent host, ensure AppSync Host Plug-in service is in running state. If this is a Unix agent host, verify ssh service.

06-24-2025 15:41:57.218 ERROR [EJB default - 1] [com.emc.archway.service.sshservice.SecureShellSession] [AppSync server] [] Error while Connecting to host : <UNIX_HOST> : Auth cancel


 

Cause

AppSync agent host and the AppSync server version compatibility mismatch, as per the the support matrix, then there are intermittent agent connectivity issues.

Resolution

1. Reset SSH key from AppSync UI using below steps
Login to AppSync UI >  Settings > Infrastructure resources > Server/Clusters > Select the host > click More> Reset SSH key.

2. If the reset keys did not worked, ping AppSync server to agent server using command prompt. 

Article Properties
Article Number: 000338736
Article Type: Solution
Last Modified: 18 Jul 2025
Version:  1
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