PowerStore: Adding an appliance to an existing cluster fails with "Unconfigured Faulted."
Summary: During Initial Configuration Wizard installation (ICW), or when adding an appliance to an existing cluster, the task fails with "Unconfigured Faulted"
Symptoms
During initial installation of an appliance to a new Cluster, or when adding a new appliance to an existing Cluster, there are hardware and network checks that can fail. This failure may change the status of the appliance from "Unconfigured" to "Unconfigured Faulted." This state means that the appliance cannot join a new cluster, or be added to an existing cluster. The fault must be cleared before the appliance can be added to a cluster.
Cause
In order to determine if there is a hardware or network issue that is causing the "Unconfigured Faulted" condition, perform the following steps:
Resolution
If you are adding the appliance to an existing Cluster (from the PowerStore Manager):
- Access the system using the Service LAN port access method (See PowerStore: Accessing a Node for details).
- Once logged in to the Service container as the service user, run the following Service script to determine whether there is a hardware or network issue:
svc_diag list --icw_hardware svc_diag list --network - If no errors or issues are reported, it is possible that the original symptoms seen during the ICW or add appliance operation were transient.
- If an error or issue is indicated, and you cannot determine how to resolve, run the following script to produce a Data Collect, and contact your Service Provider for assistance:
svc_dc run - If you are installing an appliance to a new cluster and ready to retry installation:
- Close your Discovery Tool and/or browser.
- Relaunch the Discovery Tool or open the browser with the static Service LAN IP address for Node A [i.e. 128.221.1.252].
- If the system displays that it is in an 'Unconfigured' state, resume your initial configuration/ICW steps
- Retry the Add Appliance operation to see if the task succeeds.
- In the event the task still fails, perform a Data Collection to obtain relevant logs, and contact your Service Provider for assistance.
The following is an example of successful output from " svc_diag list --icw_hardware " in the left column; the right column contains explanations of errors you may see.
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Sample Output |
Description |
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These tables consist of three columns: Summary | Field-Replaceable Unit (FRU) Name | Status Sensor value
OK = FRU status is good.
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These checks compare the FRU Status Summary values from each node. Both nodes are expected to report the same Summary value for each FRU. Recommended Action for failure:
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The status values in the left column are OK or FLT. These are read from the Fault Status Register (FSR).
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Drive-related checks include:
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The I/O Module in each slot on one node must match the I/O Module in the same slot on the peer node. This can happen if the wrong type of I/O Module is present in one node. It can also happen if each node contains one I/O Module but they are in different slots (example: slot 0 on one node, but slot 1 on the peer node). You can also see a failure here if an I/O Module is missing or powered off (see "Fault Status Register" section above).
Recommended Action for failure: Compare the part numbers of the I/O Modules in both I/O Module slots on both nodes. If there are any inconsistencies, move or replace I/O Modules as needed to correct the problem. KB Article 000125540 may also be helpful. |
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This section is a summary of the information provided above. |
The following is an example of successful output from " svc_diag_list --network" :
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Sample Output |
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