RecoverPoint for VMs: Plugin Server Data Not Present - All Your vRPA Clusters are Unreachable
Summary: No data is present when accessing the HTML5 Plugin. Individuals are presented with a banner message stating that all their vRPA clusters are unreachable and some information may be missing. This occurs after upgrading to RecoverPoint for Virtual Machines 5.3 or rarely upon installation. ...
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Symptoms
The Dashboard does not show any populated data after selecting the RecoverPoint for Virtual Machines HTML5 Plugin from within vCenter. The following message is received:
Figure 1: Screenshot of banner message "All of your vRPA clusters are unreachable."
Cause
This situation is due to an issue with the vRPA certificate being untrusted by the RP4VM Plugin Server.
While there is no specific reason as to why this happens, several situations can cause this to occur:
- The vRPA certificate may be expired
- The vRPA certificate installed may be a self-signed certificate and not the default trusted option
- The vCenter credentials used within RP4VM do not have administrative rights to download the requested certificate
- The DNS field was not implemented on the Plugin Server when it was deployed, which may lead to certificate confirmations failing
Resolution
Workaround:
- Reboot the Site Control vRPA. Since the Plugin Server receives updates from the vRPA which has Site Control, a reboot flips the Site Control IP to the other vRPA, potentially resolving the issue. If this does not work, move on to the next steps.
- Log in to vRPA Plugin Server from the vSphere Web Console.
- Disable the firewall by the following command:
/sbin/SuSEfirewall2 off
- Log in to root on the Site Control vRPA and run the following command:
scp /etc/kbox/ssl/rpa_web_server.crt root@Plugin_Server_IP:/etc/pki/trust/anchors
The Plugin Server root password, which was changed, is required to copy the vRPA certificate from the vRPA to the Plugin Server.
- Update the certificate management service on the Plugin Server by running the following command from within the vSphere Console:
update-ca-certificates
- Power off the Plugin Server, power it back on, giving it approximately two minutes to orient itself. If powering back on is done too early, internal errors and other communication issues appear in the HTML5 plug-in.
- After the two minutes pass with the Plugin Server online, log back in to the RP4VM HTML5 Plugin to see if the Dashboard was populated with cluster information
Resolution:
Dell Technologies engineering is investigating this issue. A permanent fix is still in progress. Contact the Dell Technologies Customer Support Center or your service representative for assistance and reference this solution ID.Affected Products
RecoverPoint for Virtual MachinesArticle Properties
Article Number: 000180047
Article Type: Solution
Last Modified: 22 Nov 2023
Version: 6
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