Dell Unity: Pre-Upgrade Health Check warning: platform::check_management_port_2

Summary: Pre-upgrade health check completes with warning: platform::check_management_port_2 or Upgrade pauses with the same warning.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Pre-upgrade health check or Upgrade completes with warning code:

Test of the management port configuration indicates there may be a problem with the management port VLAN settings that could cause loss of management functionality during storage processor reboots associated with the upgrade. Some valid network configurations can also make this test fail. Ensure that the alternate management port is properly configured. See KB#000066048 for recommended VLAN management port guidelines. You can safely ignore this warning if there is not a real issue.

screen shot of PUHC warning

Cause

A new Pre-Upgrade Health Check (PUHC) utility enhancement has been introduced in Unity OE 5.3 and higher. This enhancement checks for possible connectivity issues on the management ports. This warning message only indicates that the Unity array was unable to confirm the network connectivity of the peer Storage Processor (SP).

This warning message does not mean that either SP management port link is down. If there is an issue with the peer management port, the pre-upgrade health check would report a different error code.
See Knowledge Base Article (KBA) 000061985: Dell Unity: Health check fails with Error code: platform check (User Correctable)

Resolution

The new Unity OE 5.3 PUHC enhancement initiates an Address Resolution Protocol (ARP) probe to the network. This is to confirm any connectivity issue on the peer SP, in the event management operations is failed over to the peer SP.

The PUHC sends out an ARP probe instead of a standard ARP ping. The management IP address is only active on the primary SP, not the peer. This is the reason that the check must be an ARP probe on the peer. The non-primary (peer) SP does not have a configured IP address for a standard ARP. Thus, the ARP request has to be sent with 0.0.0.0 populated and is an ARP probe.

The warning message occurs if a response is not received from the ARP probe.

During PUHC prior to upgrade:
The below warning message is a soft warning and not a failure.

Warning Code: platform::check_management_port_2


Check the Unisphere UI view to see if both management ports show a green led indicating that they are operating normally.
Go to System View-> Enclosures tab, and confirm from the DPE Rear view.
management ports view

Use one of the options in KBA 000019807 to fail management operations over to the peer SP. This tests if the peer SP has connectivity with the network.


An additional option to KBA 000019807 is to reboot the current Primary SP to failover management operations to the peer SP. Management operations can be lost up to 10 minutes during the failover process. Once management operations are recovered, verify that the peer SP is now the primary SP. If management operations are successfully working on SPA and SPB after failover tests, this warning message can be safely ignored.

During the upgrade:
This warning can be ignored if it was not seen until the middle of the upgrade. Click the "Retry" button to proceed with the upgrade.  

Contact Dell Support and quote this Knowledge Article, in the event the "Retry" button does not work.

After a successful upgrade:
The below warning message can be safely ignored if this warning message was received after a successful upgrade to Unity OE 5.3 or higher.

Warning Code: platform::check_management_port_2
NOTE:  If failover of management operations does not return after 5-10 minutes during any of the above tests, reference KBA 000066048 Dell Unity: Unity not reachable after Primary SP reboot during upgrade (User correctable) to troubleshoot management connectivity.


 

Additional Information

Why the warning occurs:
When the array sends out the ARP probe from the non-primary SP and receives no response, it reports this soft warning.

When an ARP response is seen:

  • The non-primary SP can communicate with the network at minimum of the layer 2 level.
  • This further verifies access to management once failover occurs during an upgrade.
  • The PUHC warning is not present.

When an ARP response is not seen:

  • The non-primary SP is unable to confirm network connectivity.
  • Depending on network configurations, an ARP probe response may not be received.
  • PUHC check fails, and the warning is present.
  • This warning indicates something outside of the array preventing the non-primary SP from receiving an ARP probe response from the network.


In addition to the above, this test may produce a false negative on the peer SP. If the switch is configured to allow broadcasts across VLANs, the test may produce a false positive when broadcasts are disabled, even within a VLAN. Usually, under normal conditions, this new test determines whether or not the management ports are properly configured in a VLAN.

 

Affected Products

Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid
Article Properties
Article Number: 000214814
Article Type: Solution
Last Modified: 31 Oct 2024
Version:  7
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