SourceOne Email Management: SourceOne creates more than 1 ElasticSearch index when converting ISYS indexes or when a new month folder is created.
Summary: SourceOne creates more than 1 ElasticSearch index when converting ISYS indexes or when a new month folder is created.
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Symptoms
This issue can be seen slightly differently depending on the environmental factors and configuration settings. Several ISYS indexes should convert into a single ElasticSearch index and only when a certain threshold calculated based on different factors (number of messages, number of volumes, custom settings in the Archive folder, etc) should roll over to a new ElasticSearch. Usually, the ElasticSearch index will grow up to several GB before rolling over to the next ElasticSearch Index.
ElasticSearch presents performance issues when data nodes exceed 500 Shards. The more a user exceeds this value the greater the performance issue and it will increase the chances of experiencing the issues explained below:
The user is converting ISYS indexes to ElasticSearch and will see SourceOne creating several ElasticSearch indexes during the conversion. Most of these indexes will be smaller than a 1 GB in size and the latest Index created will hold most of the data converted from ISYS.
2.- User running Journaling or Historical Archive activities observes that SourceOne creates 2 ElasticSearch indexes when a new month folder is created.
User will see 2 ElasticSearch indexes on the newly created month folder: 1 Index will contain only few MB of information and the next Index will contain most of the data being added to the month folder.
Cause
This problem is caused by a software defect
The issue is may be caused by performance issues in the ElasticSearch cluster and environment running more than 1 Archive servers.
This issue is caused when more than 1 Archive server picks up a transaction file (xvlts) or a .convert file (ISYS conversion to ElasticSearch) and the ElasticSearch performance issues causes a delay creating the Index in the cluster. That creates the sufficient window during which another server could pick up a transaction file and determine that a new ES index is needed, which can result in extra indexes.
The issue is may be caused by performance issues in the ElasticSearch cluster and environment running more than 1 Archive servers.
This issue is caused when more than 1 Archive server picks up a transaction file (xvlts) or a .convert file (ISYS conversion to ElasticSearch) and the ElasticSearch performance issues causes a delay creating the Index in the cluster. That creates the sufficient window during which another server could pick up a transaction file and determine that a new ES index is needed, which can result in extra indexes.
Resolution
This issue will be resolved in patches or Service Pack versions of EMC SourceOne Email Management post 7.2.7.7034 (HFB2)
Hotfix Bundles and Service Pack kits are available for download via https://www.dell.com/support.
* Please note, Hotfixes are only available for the most current patch or Service Pack versions of the product that were available when this problem was resolved.
** Please note that it is always recommended to upgrade to the latest version of the SourceOne release, service pack and Hot Fix Bundle to ensure all currently resolved issues will be fixed including the issue as stated above
Hotfix Bundles and Service Pack kits are available for download via https://www.dell.com/support.
* Please note, Hotfixes are only available for the most current patch or Service Pack versions of the product that were available when this problem was resolved.
** Please note that it is always recommended to upgrade to the latest version of the SourceOne release, service pack and Hot Fix Bundle to ensure all currently resolved issues will be fixed including the issue as stated above
Affected Products
SourceOne Email ManagementProducts
SourceOne, SourceOne Email ManagementArticle Properties
Article Number: 000055966
Article Type: Solution
Last Modified: 26 May 2025
Version: 4
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