Avamar: Data Domain Integration: Checkpoint backups to Data Domain fail due to the incorrect ownership of backupupgradefiles.tar

Summary: Checkpoint backups to the Data Domain fail if the /tmp/backupupgradefiles.tar file exists with root ownership.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Overview:

Checkpoint backups save a copy of the checkpoints from a Single node Avamar server, AVE, VDP, or VBA to the Data Domain for disaster recovery. 

 

Symptoms:

No checkpoint backup (cpbackup) is created on the Data Domain (DD).

The following events can be seen in the /usr/local/avamar/var/client/cpbackup-cp.<tag>.log:

grep -i "tar.*denied" /usr/local/avamar/var/client/cpbackup-cp.20161026142704-101850.log
[Mon Oct 31 09:34:48 2016] Backup upgrade files path: /tmp/backups_20161031_093448
[Mon Oct 31 09:34:48 2016] Creating /tmp/backupupgradefiles.tar
[Mon Oct 31 09:34:48 2016] Execute: tar -cvf /tmp/backupupgradefiles.tar -C /tmp/backups_20161031_093448 . 2>&1
[Mon Oct 31 09:34:48 2016] Execute output:
tar: /tmp/backupupgradefiles.tar: Cannot open: Permission denied
 tar: Error is not recoverable: exiting now
..
[Mon Oct 31 09:34:48 2016] Error code: 2
[Mon Oct 31 09:34:48 2016] Changing permissions for /tmp/backupupgradefiles.tar
[Mon Oct 31 09:34:48 2016] Execute: chmod a+r /tmp/backupupgradefiles.tar 2>&1
[Mon Oct 31 09:34:48 2016] Error code: 1
..
 ddrmaint cp-backup-finish Command failed. Error code: 1.

 

 

Cause

First seen after an upgrade to Avamar v7.3.0.226, the checkpoint backup to Data Domain fails if the /tmp directory contains the backupupgradefiles.tar file with root ownership.

In Avamar 7.3.0.226 MCS cannot access the /tmp/backupupgradefiles.tar file if it is owned by root user.

This file is removed at the end of every successful checkpoint backup operation.

A failure in the checkpoint backup operation can leave the backupupgradefiles.tar file in the /tmp directory.

Resolution

Although the issue should be resolved for Avamar Versions 7.5 and higher, it is worth verifying that this is not the issue:

1. Log in to the Avamar Utility Node as admin.

2. Elevate to root privilege.

3. Assuming it exists, remove the /tmp/backupupgradefiles.tar file.

4. Allow the next checkpoint backup to run during the maintenance window (after the hfscheck).

5. If there are still errors with the checkpoint backups, Create a Service Request with the Dell Technologies Avamar Support team.

Affected Products

Avamar

Products

Avamar, Avamar Server
Article Properties
Article Number: 000063116
Article Type: Solution
Last Modified: 19 May 2025
Version:  6
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