Avamar: SQL-back-upbewerkingen reageren willekeurig niet meer, waardoor avsql- en avtar-processen vastlopen

Summary: Willekeurig tijdens een Avamar-back-up ziet een klant dat de back-up niet meer reageert en dat handmatige interventie vereist is.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Willekeurig tijdens een Avamar-back-up ziet een klant dat de back-up niet meer reageert en dat handmatige interventie vereist is.
Dit gedrag wordt meestal gezien tijdens back-ups van grote databases en multi-streaming ingeschakeld.
<flag type="pulldown" pidnum="3006" value="4" name="max-parallel" />
    <flag type="pulldown" pidnum="3006" value="1024" name="min-snapup-size" /> 
Dezelfde serverback-up wordt de volgende keer met succes uitgevoerd en vertoont deze symptomen mogelijk een tijdje niet meer.

Wanneer de respons wordt gestopt, stopt de dataverwerking totdat er een time-out optreedt voor de Virtual Backup Device Interface (VDI) volgens de instellingen "vditransfertimeoutsecs". In het geval van de klant was het ingesteld op 3 uur en we zien de time-out voor avsql_t3 thread in het onderstaande fragment:
 
2019-11-05 19:43:27 avsql Info <42988>: VDC_Complete is not supported by VDI.
2019-11-05 19:43:27 avsql Error <6478>: VDS::Getconfig failed with 'The api was waiting and the timeout interval had elapsed'
2019-11-05 19:43:27 avsql Error <6479>: Timed out. Was Microsoft SQLServer running?
2019/11/06-00:43:27.75200 [avsql_t3] Canceling avtar sub-process ... 
Hier loopt de avsql_t3 thread vast na het aanroepen van GetConfiguration van de SQL VDI-functie.

Cause

Er is een softwarefout in het onderdeel GetConfiguration() van de Microsoft SQL VDI API/functie die de Avamar plug-in gebruikt.

Resolution

De softwarefout wordt onderzocht door Avamar en Microsoft-ontwikkelaars. 

Neem contact op met Avamar Support voor de nieuwste update.

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000068644
Article Type: Solution
Last Modified: 05 Sep 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.