NMDA: DB2 backups fail with "Error retrieving password from the NetWorker lockbox"
Summary: NetWorker Module for Database Applications (NMDA) DB2 backups fail with "Error retrieving password from the NetWorker lockbox"
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Symptoms
- NMDA DB2 backups fail with the following error reported in the NetWorker Management Console (NMC):
Unable to obtain the user credentials from the lockbox due to the following error: 'Authentication denied'.ERROR: Error retrieving password from the Networker lockbox.
NMDA backup failed.
72104:nsrdasv: ERROR: Error retrieving password from the Networker lockbox.
- This output can be observed from the Policy->Workflow->Backup action details. Select the failed backup and click Show Messages.
Cause
The root account on the DB2 client does not have permissions to access the lockbox file.
Resolution
1. Log in to the NetWorker Management Console as the Administrator account (or an account with Application Administrators privileges).
2. Go to Server->Lockboxes.
3. In the Lockboxes window, open the DB2 client's lockbox properties.
4. In the General tab, update the Users field to contain "user=root,host=client_name"

5. Save the changes by clicking OK.
6. Rerun the backup.
Affected Products
NetWorker, NetWorker Module for Databases and ApplicationsProducts
NetWorker Family, NetWorker SeriesArticle Properties
Article Number: 000211900
Article Type: Solution
Last Modified: 30 Apr 2025
Version: 3
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