NMDA : Les sauvegardes DB2 échouent avec l’erreur « Error retrieving password from the Networker lockbox »

Summary: Les sauvegardes DB2 de NetWorker Module for Database Applications (NMDA) échouent avec l’erreur « Error retrieving password from the Networker lockbox »

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Les sauvegardes NMDA DB2 échouent avec l’erreur suivante signalée dans NetWorker Management Console (NMC):
Unable to obtain the user credentials from the lockbox due to the following error: 'Authentication denied'.ERROR: Error retrieving password from the Networker lockbox.

NMDA backup failed.

72104:nsrdasv: ERROR: Error retrieving password from the Networker lockbox.
  • Ce résultat peut être observé à partir des détails de l’action Policy->Workflow->Backup. Sélectionnez la sauvegarde en échec, puis cliquez sur Afficher les messages.

Cause

Le compte root du client DB2 ne dispose pas des autorisations nécessaires pour accéder au fichier du lockbox.

Resolution

1. Connectez-vous à NetWorker Management Console en tant que compte administrateur (ou compte disposant de privilèges Administrateurs d’applications).
2. Accédez à Server->Lockboxes.
3. Dans la fenêtre Lockboxes , ouvrez les propriétés du lockbox du client DB2.
4. Dans l’onglet Général , mettez à jour le champ Utilisateurs pour qu’il contienne « user=root,host=client_name »

image.png

5. Enregistrez les modifications en cliquant sur OK.
6. Réexécutez la sauvegarde

 

Affected Products

NetWorker, NetWorker Module for Databases and Applications

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000211900
Article Type: Solution
Last Modified: 30 Apr 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.