PPDM - Reporting engine not generating any reports. No data to display.
Summary: PowerProtect Data Manager reporting engine never generates any reports, always showing "No data to display," due to the DNS issue on the reporting node.
Symptoms
After deploying the reporting engine, it never generated reports. Always showing "No data to display."
From the /var/log/reporting/logs/agent/dpaagent.log, you could see below messages indicating the certificate generation failed, following by the name resolution failure of PowerProtect Data Manager appliance.
INFO 12263.12330 20240530:163624 com.emc.dpa.agent.mo - authenticate(): Certificates are being setup... INFO 12263.12330 20240530:163729 com.emc.dpa.agent.mo - authenticate(): Using authType CERT INFO 12263.12330 20240530:163729 com.emc.dpa.agent.mo - authenticate(): Attempting CREDS token, as the certificate based token generation is failed. ...... WARN 12263.12330 20240530:163739 com.agent.worker - runAgentWorkerRequest(): Received unexpected output from worker: Caused by: java.net.UnknownHostException: ppdm.local: Temporary failure in name resolution
Confirmed that the status of the reporting node is ready.
Confirmed that the time is synced between the reporting node and the PowerProtect Data Manager server."./ppcp rest --uri whitelist" shows the correct reporting node with the expiration time in the future.
Cause
Log in to the PowerProtect Data Manager appliance as user root, run below command to get the credentials of the reporting node.
source /opt/emc/vmdirect/unit/vmdirect.env && /opt/emc/vmdirect/bin/infranodemgmt get -secret -node_type ReportingNode
Then, log in to the reporting node, uncomment the below line and run the /opt/emc/dpa/agent/etc/setup_ppdm_certificate.sh script.
The script failed with HTTP_CODE=000, this usually happens when the node with which you are trying to exchange the certificate is not reachable. 
On the reporting node, 'cat /opt/emc/dpa/agent/data/ppdm/ppdm.ip', then run 'nslookup <host return from ppdm.ip>'. The nslookup failed with "connection timed out."
The failure of resolving the PowerProtect Data Manager appliance from the reporting node caused the certificate generation failed. Thus, failing to generate report although the node status looks good.
Resolution
- Modify /etc/resolv.conf on the reporting node to use the proper DNS server.

- Rerun the /opt/emc/dpa/agent/etc/setup_ppdm_certificate.sh script, it should show below success result.
- Wait for the backup job to run, then the report could generate proper data.