PowerEdge: SK Hynix PS1010 and PS1030 NVMe reports PCIe bus fatal error and operating system PSOD
Summary: When a PS1010 or PS1030 NVMe SSD is installed, a PSOD may occur during production or gathering Operating System (OS) logs.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
SK Hynix PS1010 and PS1030 NVMe SSD drives with firmware version 1.0.0 may see a PCIe bus fatal error and an OS crash.
This condition may be seen in production while the drives are under a heavy I/O workload. It may also be seen in some scenarios when a vm-support is gathered or when a TSR log with OS data is included.
Screenshot of PSOD:
LifeCycle Log example:
2024-09-11 01:41:59 PCI1318 A fatal error was detected on a component at bus 21 device 8 function 0.
2024-09-11 01:41:58 PCI1319 A high-severity issue is detected in the SSD bay 2, Slot 15.
2024-09-11 01:41:56 PCI1318 A fatal error was detected on a component at bus 21 device 8 function 0.
2024-09-11 01:41:54 PCI1319 A high-severity issue is detected in the SSD bay 2, Slot 15.
- The location where the Bus Fatal Error occurs may vary depending on the drive configuration.
- The issue has been reported in vSAN ESA environments but may also be present in vSAN OSA.
- PCIe bus fatal errors on PS10x0 drives may potentially be seen in Windows and Linux operating systems.
Cause
The PS1010 and PS1030 NVMe drives may see this error due to internal drive tasks being delayed and not completed within a determined timeframe.
Resolution
Update the PS1010/PS1030 NVMe SSD to firmware version 1.2.0 or later; the firmware update package is compatible with both drive models.
https://www.dell.com/support/home/drivers/DriversDetails?driverID=3X8R4
Note: Upgrading the PS1010/PS1030 drives from firmware version 1.0.0 to any higher version requires a system power cycle. The drive displays the updated firmware in the iDRAC UI and OS utilities but may continue to experience PCIe errors until a power cycle is completed. To accomplish this step, power the system down fully and then power it back on after the firmware update has been applied.
Affected Products
VxRail, Dell EMC vSAN Ready Nodes, AX-750, AX-760, Dell EMC XC Core XC650, Dell EMC XC Core XC750, Dell EMC XC Core XC750xa, Dell PowerEdge Express Flash NVMe PCIe SSD, Dell XC Core XC660, Dell XC Core XC760, Dell XC Core XC760xa, Dell XC Core XC7625
, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R470, PowerEdge R540, PowerEdge R550, PowerEdge R570, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R7715, PowerEdge R7725, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge XR11, PowerEdge XR12, PowerEdge XR5610, PowerEdge XR7620, PowerFlex appliance R650, Powerflex appliance R750, PowerFlex custom node R650, PowerFlex custom node R750, VMware VSAN, VxRail E660N, VxRail E665N, VxRail P670N, VxRail P675N, VxRail VE-660, VxRail VP-760, Dell EMC XC Core XC7525
...
Article Properties
Article Number: 000228837
Article Type: Solution
Last Modified: 05 Aug 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.