Dell EMC Unity: Automatic refresh of the contract data failed
Summary: Dell EMC Unity: Automatic refresh of the contract data failed (User Correctable)
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Error message received about "An automatic refresh of the contract data failed" or "contracts cannot be validated".
The service was unavailable or unreachable in the Unity storage.
AlertID Message
14:380005 An automatic refresh of the contract data failed. The service was unavailable or unreachable.
14:380006 An automatic refresh of the contract data failed.
Cause
Unity is attempting to reach the Dell EMC servers to verify Support Contract Status. It uses port 80 and 443 outbound.
This is separate from ESRS traffic on the Unity array.
This is separate from ESRS traffic on the Unity array.
Resolution
Option 1:
Once this is complete the alerts should stop.
Option 3:
Once this is complete the alerts should stop.
Confirm that ports 80 and 443 are open.
support.emc.com port --> 443
uemconnect.emc.com --> 80
support.emc.com port --> 443
uemconnect.emc.com --> 80
If there is a proxy server make sure it is correctly configured
Option 2:
In an environment where only port 443 is allowed and port 80 is disallowed, the following can be used as a workaround:
- Login as Service user via SSH to Unity
- Run the following command:
echo 'https://uemconnect.emc.com/' > /tmp/contractdataurl.txt
Once this is complete the alerts should stop.
Option 3:
If the storage administrator does not wish to open ANY ports, the contract check can be disabled as follows:
- Login as Service user via SSH to Unity
- Run the following command:
uemcli -u admin -p <pass> /sys/support/config set -autoUpdateContracts no
Once this is complete the alerts should stop.
Affected Products
Dell EMC Unity FamilyProducts
Dell EMC Unity FamilyArticle Properties
Article Number: 000052576
Article Type: Solution
Last Modified: 17 Mar 2025
Version: 4
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