SourceOne Email Management - Index Sets are in an “Unperformed Transaction” state.

Summary: SourceOne Email Management - Index Sets are in an “Unperformed Transaction” state.

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Symptoms



Index Sets in the SourceOne Email Management Console have a state of  Unperformed Transaction .

The following event will be recorded in the EMC event logs:

Log Name:      EMC
Source:        EMC SourceOne
Date:          <Date\Time>
Event ID:      11080
Task Category: ExAsIdxObj
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      <SERVER>
Description:
[ArchiveFolder_YearMonth_IndexSet] Failed to process transaction <SHARE TO XVLTS\UPDS> (0x86042B48) [ExAsIdxObj.exe, IndexThread.cpp(1294).IndexThread::IdxCmdPollByType] 

Any search against these index sets, either through SourceOne Web Search or Discovery Manager, will log an error similar to the following:

Unperformed transactions in index. (Occurred 1 time(s))               

Error Detail: 21:(ArchiveFolder_YearMonth_IndexSet) (1 / 1) Search results may be incomplete, <\\ServerShare\ArchiveFolder\YearMonth\IndexSet> has unperformed transaction issues. (0x86042D22) (0x86044109)

Cause

Indexing jobs in the Index\DropDir are referred to as Transactions. These jobs can include new message indexing (.xvlts\.txvlts) and Owner Updates (.upds\.tupds) transactions, where the transactions contain references to individual messages which need to be indexed or where ownership needs to be updated.

An  Unperformed Transaction  occurs when, after several attempts, the ExAsIdxobj.exe\ExAsElasticIDxObj.exe process is unable to process a message referenced in the transaction file located in the index DropDir folder. The problematic transaction file is moved from the index DropDir to the DropDir\Intermediary folder and the associated index set for the transaction in question is place in an  Unperformed Transaction  state in the SourceOne Email Management Console.

Resolution

To resolve the issue perform the following steps.

Reprocess the transaction file

1.    Identify the associated transaction files in the DropDir\Intermediary folder for the index set that is marked as  Unperformed Transaction . The filename will be in the following naming format: 

ArchiveFolder_YearMonth_IndexSet.xvlts or ArchiveFolder_YearMonth_IndexSet.upds

2.    Move the file from the Intermediary folder back into the DropDir folder and allow it to process again.

3.    If the transaction processes successfully, the associated index set will be marked as  Available  and the transaction file will be removed from the DropDir.

4.    If the transaction files is again moved to the Intermediary folder, attempt to rebuild the index set.

                NOTE: It is important that the transaction is NOT copied from the Intermediary folder to the DropDir. The file must be moved.

Rebuild the index set

1.    If reprocessing the transaction file is again moved into the DropDir\Intermediary folder, attempt to rebuild the index set in question. 

2.    Once the rebuild is complete and the index set is marked in an  Available  state, delete the associated transaction file from the DropDir\Intermediary folder.

NOTE: If both reprocessing the transaction file and rebuilding the index set does not resolve the issue, it is recommended to upgrade to the latest version of SourceOne Email Management. Once the upgrade is complete, the same resolution steps should be repeated.

Affected Products

SourceOne Email Management

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000057004
Article Type: Solution
Last Modified: 02 Jun 2025
Version:  6
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