PPDM File System agent Data restore fails with error code ARF0032

Summary: PowerProtect Data Manager File System agent Data restore fails with error code ARF0032, Unable to perform a file-level restore.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

These messages are associated with the failure:

File System agent Data restore fails with error code ARF0032, Unable to perform a file-level restore at ######### to the target volume drive-letter:\Restore because the third party component Robocopy produced the following error: the exit code is 9, several files did not copy.

The restore of this backup copy cannot be completed because an operation by a third party component was unsuccessful. Robocopy recovers with 1 error, check detail in log C:\Program Files\DPSAPPS\fsagent\logs\

To troubleshoot this issue:

  1. Verify that there is sufficient disk space in the target volume. When the issue is resolved, retry the operation.
  2. The backup source may have been unmounted due to a timeout, with the default duration. The PowerProtect Data Manager FS user guide provides more information about increasing the timeout.

Cause

Restore takes longer than the restore timeout value.

Resolution

Increase Restore Timeout

***Increasing the restore timeout***
By default, the mount operation times out after 30 minutes and the backup copy is unmounted. When running file-level restores of large files, you can increase the restore timeout.

Perform this task if file-level restores for large files timeout before completing.

  1. Create a file with the name browsersvc.cmd in one of the following locations:
    • On Windows, C:\Program Files\DPSAPPS\fsagent\settings
    • On Linux, /opt/dpsapps/fsagent/settings
  2. Add the following line to the file, and specify the same timeout value, in minutes, for both variables:
    • {"-idletimeout":"timeout", "-resexpiry":"timeout"}
      • For example, enter this line to set the restore timeout to 60 minutes:
      • {"-idletimeout":"60", "-resexpiry":"60"}

Affected Products

PowerProtect Software
Article Properties
Article Number: 000228692
Article Type: Solution
Last Modified: 29 Jan 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.