SourceOne Email Management: Jobs fail due to SQL connection failure after migrating SourceOne databases to a new SQL server

Summary: Jobs fail due to SQL connection failure after migrating SourceOne databases to a new SQL server. Error: SQL Server does not exist or access denied.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



After moving Dell-EMC SourceOne databases to a new SQL server and the site is using the same SQL server alias Dell-EMC SourceOne Email Management jobs are marked as 'Failed' in the EMC SourceOne Jobs node of the Console application.
The EMC event-log on the SourceOne worker where the job was assigned logs an SQL connection error:

"SQL Server does not exist or access denied".

Cause

This problem can occur when the SQL server configuration has been configured on SourceOne servers using the 'SQL Client Configuration Utility' and the configuration has not been updated with the new SQL server information. The SQL client is being redirected to the old SQL server even though the odbcad32.exe settings are correct.

Resolution

Run C:\Windows\SYSWOW64\cliconfg.exe on Dell-EMC SourceOne servers.
If the Alias tab is empty, this solution does not apply.
If there is an entry on the Alias tab and the alias is valid for the current SQL server,
Edit the connection and update the 'Server name' with the new SQL server name or IP address.

Affected Products

SourceOne

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000063401
Article Type: Solution
Last Modified: 02 Jun 2025
Version:  5
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