Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell SmartFabric OS10 User Guide Release 10.5.3

PDF

Auto-unnumbered interfaces for BGP

Although the BGP unnumbered feature provides an easier way of configuring BGP, you can use the BGP auto-unnumbered feature to reduce configuration overhead.

The BGP auto-unnumbered feature works similar to the BGP unnumbered feature. However, with the BGP auto-unnumbered feature configured, the switch automatically establishes BGP sessions on interfaces that learn the link-local addresses of peer devices.

Restrictions

All restrictions that are applicable for the BGP unnumbered feature are also applicable for the BGP auto-unnumbered feature.

Prerequisites

  • Enable RA advertisement on the required interfaces by using the ipv6 nd send-ra command.
  • If you configure RA timers globally and on individual interfaces, interface level RA timers take precedence. In the absence of interface level RA, global RA timers are applied to all interfaces.
  • Configure the global RA timers. Dell Technologies recommends that you configure three seconds for the minimum and four seconds for the maximum RA timer.
  • Configure the physical and port channel interfaces to operate in Layer 3 mode by using the no switchport command. VLAN interfaces do not require this configuration.
  • Configure the ipv6 bgp unnumbered {ebgp-template | ibgp-template} command on the required interfaces. For the BGP auto-unnumbered feature to work, you must specify the type of the template.
  • While forming BGP neighborship on an interface, the system uses the corresponding template that is configured under the ROUTER-BGP-NEIGHBOR mode.

  • Template configuration is optional. If there is no template configured, neighborship comes up with default parameters.
  • The template type configuration is only used when there is a valid inherit template configuration on the neighbor with the auto-unnumbered configuration. For example, the ipv6 bgp unnumbered ebgp-template configuration requires the corresponding inherit ebgp-template configuration.
  • An explicit BGP unnumbered configuration using the neighbor interface command brings down any BGP sessions that are formed using the auto-unnumbered configuration on that interface. The system brings a new session with new configured parameters.
  • If you delete the explicit neighbor configuration which is already configured, the BGP sessions are brought down. If there is an interface-level auto-unnumbered configuration, the system tries to bring up the BGP session with the unnumbered-auto neighbor configuration.

Software behavior

  • If you delete an interface that is configured as a BGP auto-unnumbered interface which is already in established state, the established state is brought down.
  • If you configure the default interface command on an interface that is configured as a BGP auto-unnumbered interface which is already in established state, the established state is brought down.

Configure an auto-unnumbered neighbor

To configure an auto-unnumbered neighbor:

  1. Configure minimum and maximum RA intervals in CONFIGURATION mode.
    ipv6 nd min-ra-interval interval
    ipv6 nd max-ra-interval interval
  2. Configure physical or port-channel interfaces as Layer 3 interfaces in INTERFACE mode.
    interface range ethernet 1/1/1-1/1/4
    no shutdown 
    no switchport
  3. Enable RAs on the interfaces in INTERFACE mode.
    ipv6 nd send-ra
  4. Configure the interfaces as BGP auto-unnumbered interfaces in INTERFACE mode.
    ipv6 bgp unnumbered {ebgp-template | ibgp-template}
  5. Enable BGP on the device in CONFIGURATION mode.
    router bgp as-number
  6. Create a template, and assign parameters to the template in ROUTER-BGP mode.
    template template-name
    timers keepaliveholdtime
  7. Create a BGP auto unnumbered neighbor in ROUTER-BGP mode.
    neighbor unnumbered-auto
    no shutdown
  8. Configure the peer group template that the neighbors use to inherit peer-group configuration in ROUTER-NEIGHBOR mode. This template is applied only to the auto-unnumbered interfaces configured with the ipv6 bgp unnumbered command.
    inherit {ebgp-template | ibgp-template} template-name
    NOTE: The inherit ebgp-template and inherit ibgp-template commands apply the template configurations to all auto-unnumbered interfaces that are configured with the ipv6 bgp unnumbered ebgp-template command.
  9. Enable the IPv6 address family to advertise IPv6 routes in ROUTER-NEIGHBOR mode. IPv4 address family is activated by default.
    address-family ipv6 unicast
    activate
  10. Enable EVPN address family to advertise EVPN routes in ROUTER-NEIGHBOR mode.
    address-family l2vpn evpn
    activate

Example auto-unnumbered BGP configuration

In the following figure, Router A and Router B share eBGP routes. Router B and Router C share iBGP routes. This section provides a sample configuration for this topology.

Auto-unnumbered BGP configuration

Router A configuration

  1. Configure recommended RA timers globally for fast convergence in CONFIGURATION mode.
    OS10-A(config)# ipv6 nd min-ra-interval 3
    OS10-A(config)# ipv6 nd max-ra-interval 4
  2. Make the required interfaces in CONFIGURATION mode and convert them to Layer 3 routing interfaces.
    OS10-A(config)# interface range ethernet 1/1/1-1/1/4
    OS10-A(conf-range-eth1/1/1-1/1/4)# no shutdown 
    OS10-A(conf-range-eth1/1/1-1/1/4)# no switchport
  3. Enable RA transmission on all the interfaces in the range in INTERFACE mode.
    OS10-A(conf-range-eth1/1/1-1/1/4)# ipv6 nd send-ra 
  4. Configure the interfaces as BGP auto-unnumbered interfaces in INTERFACE mode.
    OS10-A(conf-range-eth1/1/1-1/1/4)# ipv6 bgp unnumbered ebgp-template
  5. Create BGP instance in CONFIGURATION mode.
    OS10-A(config)# router bgp 100
  6. Create a template and assign necessary parameters in ROUTER-BGP mode.
    OS10-A(config-router-bgp-100)# template ext-bgp
    OS10-A(config-router-template)# timers 120 360
  7. Enable the BGP auto-unnumbered neighbor feature in ROUTER-BGP mode.
    OS10-A(config-router-bgp-100)# neighbor unnumbered-auto
    OS10-A(config-router-neighbor)# no shutdown
  8. Configure the peer group template that the neighbors use to inherit peer-group configuration in ROUTER-NEIGHBOR mode. This template is applied only to the auto-unnumbered interfaces configured with the ipv6 bgp unnumbered command.
    OS10-A(config-router-neighbor)# inherit ebgp-template ext-bgp
  9. Enable IPv6 address family to advertise IPv6 routes in ROUTER-NEIGHBOR mode.
    OS10-A(config-router-neighbor)# address-family ipv6 unicast
    OS10-A(config-router-bgp-neighbor-af)# activate
  10. Enables EVPN address family to advertise EVPN routes in ROUTER-NEIGHBOR mode.
    OS10-A(config-router-neighbor)# address-family l2vpn evpn
    OS10-A(config-router-bgp-neighbor-af)# activate

Router B configuration

  1. Configure recommended RA timers globally for fast convergence in CONFIGURATION mode.
    OS10-B(config)# ipv6 nd min-ra-interval 3
    OS10-B(config)# ipv6 nd max-ra-interval 4
  2. Make the required interfaces in CONFIGURATION mode and convert them to Layer 3 routing interfaces.
    OS10-B(config)# interface range ethernet 1/1/1-1/1/8
    OS10-B(conf-range-eth1/1/1-1/1/8)# no shutdown 
    OS10-B(conf-range-eth1/1/1-1/1/8)# no switchport
  3. Enable RA transmission on all the interfaces in the range in INTERFACE mode.
    OS10-B(conf-range-eth1/1/1-1/1/8)# ipv6 nd send-ra 
  4. Configure the interfaces as BGP auto-unnumbered interfaces in INTERFACE mode.
    OS10-B(conf-range-eth1/1/1-1/1/4)# ipv6 bgp unnumbered ebgp-template
    OS10-B(conf-range-eth1/1/5-1/1/8)# ipv6 bgp unnumbered ibpg-template
  5. Create BGP instance in CONFIGURATION mode.
    OS10-B(config)# router bgp 100
  6. Create a template and assign necessary parameters in ROUTER-BGP mode.
    OS10-B(config-router-bgp-100)# template ext-bgp
    OS10-B(config-router-template)# timers 120 360
  7. Enable the BGP auto-unnumbered neighbor feature in ROUTER-BGP mode.
    OS10-B(config-router-bgp-100)# neighbor unnumbered-auto
    OS10-B(config-router-neighbor)# no shutdown
  8. Configure the peer group template that the neighbors use to inherit peer-group configuration in ROUTER-NEIGHBOR mode. This template is applied only to the auto-unnumbered interfaces configured with the ipv6 bgp unnumbered command.
    OS10-B(config-router-neighbor)# inherit ebgp-template ext-bgp
  9. Enable IPv6 address family to advertise IPv6 routes in ROUTER-NEIGHBOR mode.
    OS10-B(config-router-neighbor)# address-family ipv6 unicast
    OS10-B(config-router-bgp-neighbor-af)# activate
  10. Enables EVPN address family to advertise EVPN routes in ROUTER-NEIGHBOR mode.
    OS10-B(config-router-neighbor)# address-family l2vpn evpn
    OS10-B(config-router-bgp-neighbor-af)# activate

Router C configuration

  1. Configure recommended RA timers globally for fast convergence in CONFIGURATION mode.
    OS10-C(config)# ipv6 nd min-ra-interval 3
    OS10-C(config)# ipv6 nd max-ra-interval 4
  2. Make the required interfaces in CONFIGURATION mode and convert them to Layer 3 routing interfaces.
    OS10-C(config)# interface range ethernet 1/1/1-1/1/4
    OS10-C(conf-range-eth1/1/1-1/1/4)# no shutdown 
    OS10-C(conf-range-eth1/1/1-1/1/4)# no switchport
  3. Enable RA transmission on all the interfaces in the range in INTERFACE mode.
    OS10-C(conf-range-eth1/1/1-1/1/4)# ipv6 nd send-ra 
  4. Configure the interfaces as BGP auto-unnumbered interfaces in INTERFACE mode.
    OS10-C(conf-range-eth1/1/1-1/1/4)# ipv6 bgp unnumbered ibgp-template
  5. Create BGP instance in CONFIGURATION mode.
    OS10-C(config)# router bgp 100
  6. Create a template and assign necessary parameters in ROUTER-BGP mode.
    OS10-C(config-router-bgp-100)# template int-bgp
    OS10-C(config-router-template)# weight 100
  7. Configure the BGP auto-unnumbered neighbor in ROUTER-BGP mode.
    OS10-C(config-router-bgp-100)# neighbor unnumbered-auto
    OS10-C(config-router-neighbor)# no shutdown
  8. Configure the peer group template that the neighbors use to inherit peer-group configuration in ROUTER-NEIGHBOR mode. This template is applied only to the auto-unnumbered interfaces configured with the ipv6 bgp unnumbered command.
    OS10-C(config-router-neighbor)# inherit ibgp-template int-bgp
  9. Enable IPv6 address family to advertise IPv6 routes in ROUTER-NEIGHBOR mode.
    OS10-C(config-router-neighbor)# address-family ipv6 unicast
    OS10-C(config-router-bgp-neighbor-af)# activate
  10. Enables EVPN address family to advertise EVPN routes in ROUTER-NEIGHBOR mode.
    OS10-C(config-router-neighbor)# address-family l2vpn evpn
    OS10-C(config-router-bgp-neighbor-af)# activate

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\