Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell SmartFabric OS10 User Guide Release 10.5.3

PDF

QoS VXLAN usecases

The section provides an overview of the QoS Use cases in a VxLAN environment.

The following topology is used for explaining the various use cases:

qos-vxlan-usecases

The topology consists of two VTEPs with VTEP IPs 100.1.1.1 and 200.1.1.1 respectively. The VTEPs are connected with the Spine node via L3 direct uplinks. Each VTEP has two hosts connected to the access ports, which are part of VLAN 10 and 20 respectively. These two access ports are configured to be part of virtual-network 100 in the VTEP.

Virtual Network Configuration:

virtual-network 100
!
member-interface ethernet1/1/1 vlan-tag 10

member-interface ethernet1/1/2 vlan-tag 20
!
vxlan-vni 100

QoS in VxLAN Access Ports (Traffic from Access ports to Access and Network ports)

Use Case 1: Default Behavior

Consider the incoming traffic in port 1/1/1 of VTEP-1 consists of dot1p priority of 3 and DSCP value of 3.

The below behavior will be seen in the encapsulated traffic flowing out of Port 1/1/3 and the other access port 1/1/2.

The Encapsulated traffic flowing out of port 1/1/3 will have DSCP value of 3 and do not have the dot1p priority value.

The Traffic egress out of port 1/1/2 will have VLAN 20, dot1p priority 3 and DSCP value of 3.

Use Case 2: QoS Policy to match incoming vlan and set dot1p priority

Create a Class Map to match the vlan in the incoming traffic and a Policy Map to set dot1p priority of 5 and apply the same on the incoming access ports.

Dell# show running-config class-map
!
class-map type qos match_vlan_set_dot1p

match vlan 10

Dell# show running-config policy-map
!
policy-map type qos match_vlan_set_dot1p
!
class match_vlan_set_dot1p

set cos 5

Dell# show running-config interface ethernet1/1/1
!
interface ethernet1/1/1

no shutdown

switchport mode trunk

service-policy input type qos match_vlan_set_dot1p

The incoming traffic in port 1/1/1 has VLAN 10 and dot1p 3. The Policy map match_vlan_set_dot1p is applied on the interface. This results in the following:

The Encapsulated traffic flowing out of Port 1/1/3 do not have the dot1p priority set as the network ports links are L3 physical ports.

The traffic flowing out of port 1/1/2 will have VLAN 20 and dot1p priority set as 5.

Use Case 3: QoS Policy to match incoming VLAN and set DSCP

Create a Class Map to match the vlan in the incoming traffic and a Policy Map to set DSCP value of 30 and apply the same on the incoming access ports.

Dell# show running-config class-map
!
class-map type qos match_vlan_set_dscp

match vlan 10

Dell# show running-config policy-map
!
policy-map type qos match_vlan_set_dscp
!
class match_vlan_set_dscp

set dscp 30

Dell# show running-config interface ethernet1/1/1
!
interface ethernet1/1/1

no shutdown

switchport mode trunk

service-policy input type qos match_vlan_set_dscp

The incoming traffic in port 1/1/1 is an IP traffic with VLAN 10 and dot1p 3 part of the VLAN header and DSCP value of 3 in the IP header. The Policy map match_vlan_set_dscp is applied on the interface. This results in the following:

The Encapsulated traffic flowing out of Port 1/1/3 has DSCP value of 30.

The traffic flowing out of port 1/1/2 will have VLAN 20, dot1p priority 3 and DSCP value of 30.

Use Case 4: QoS Policy to match incoming VLAN and set DSCP and outgoing Queue

Create a Class Map to match the vlan in the incoming traffic and a Policy Map to set DSCP value of 30 and the desired outgoing Queue number and apply the same on the incoming access ports. This usecase describes Access to network flow.

Dell# show running-config class-map
!
class-map type qos match_vlan_set_dscp_queue

match vlan 10

Dell# show running-config policy-map
!
policy-map type qos match_vlan_set_dscp_queue
!
class match_vlan_set_dscp_queue

set dscp 30

set qos-group 4

Dell# show running-config interface ethernet1/1/1
!
interface ethernet1/1/1

no shutdown

switchport mode trunk

service-policy input type qos match_vlan_set_dscp_queue

The incoming traffic in port 1/1/1 is an IP traffic with VLAN 10 and dot1p 3 part of the VLAN header and DSCP value of 3 in the IP header. The Policy map match_vlan_set_dscp_queue is applied on the interface. This results in the following:

The Encapsulated traffic flowing out of Port 1/1/3 has DSCP value of 30 and flowing out of Queue 4.

The traffic flowing out of port 1/1/2 will have VLAN 20, dot1p priority 3 and DSCP value of 30 and flowing out of Queue 4.

Use Case 5: QoS Policy to match incoming dot1p and set DSCP and outgoing Queue

Create a Class Map to match the dot1p priority in the incoming traffic and a Policy Map to set DSCP value of 30 and the desired outgoing Queue number and apply the same on the incoming access ports.

Dell# show running-config class-map
!
class-map type qos match_dot1p_set_dscp_queue

match cos 3

Dell# show running-config policy-map
!
policy-map type qos match_dot1p_set_dscp_queue
!
class match_dot1p_set_dscp

set dscp 30

set qos-group 5

Dell# show running-config interface ethernet1/1/1
!
interface ethernet1/1/1

no shutdown

switchport mode trunk

service-policy input type qos match_dot1p_set_dscp_queue

The incoming traffic in port 1/1/1 is an IP traffic with VLAN 10 and dot1p 3 part of the VLAN header and DSCP value of 3 in the IP header. The Policy map match_dot1p_set_dscp_queue is applied on the interface. This results in the following:

The Encapsulated traffic flowing out of Port 1/1/3 has DSCP value of 30 and flowing out of Queue 5.

The traffic flowing out of port 1/1/2 will have VLAN 20, dot1p priority 3 and DSCP value of 30 and flowing out of Queue 5.

Use Case 6: QoS Policy to match incoming DSCP and set new DSCP and outgoing Queue

Create a Class Map to match the DSCP value in the incoming traffic and a Policy Map to set a new DSCP value of 30, dot1p value of 6 and the desired outgoing Queue number 6 and apply the same on the incoming access ports.

Dell# show running-config class-map
!
class-map type qos match_dscp_set_dscp_queue

match dscp 3

Dell# show running-config policy-map
!
policy-map type qos match_dscp_set_dscp_queue
!
class match_dscp_set_dscp_queue

set dscp 30

set cos 6

set qos-group 6

Dell# show running-config interface ethernet1/1/1
!
interface ethernet1/1/1

no shutdown

switchport mode trunk

service-policy input type qos match_dscp_set_dscp_queue

The incoming traffic in port 1/1/1 is an IP traffic with VLAN 10 and dot1p 3 part of the VLAN header and DSCP value of 3 in the IP header. The Policy map match_dscp_set_dscp_queue is applied on the interface. This results in the following:

The Encapsulated traffic flowing out of Port 1/1/3 has DSCP value of 30 and flowing out of Queue 6.

The traffic flowing out of port 1/1/2 will have VLAN 20, dot1p priority 6 and DSCP value of 30 and flowing out of Queue 6.

Use Case 7: QoS Policy applied on VLAN Tagged ports with Untagged access ports part of VN

Virtual Network Configuration with untagged member port

virtual-network 100
!
member-interface ethernet1/1/1 vlan-tag 10

member-interface ethernet1/1/2 untagged
!
vxlan-vni 100

Create a Class Map to match the DSCP value in the incoming traffic and a Policy Map to set a new DSCP value of 30, dot1p value of 6 and the desired outgoing Queue number 6 and apply the same on the incoming access port.

Dell# show running-config class-map
!
class-map type qos match_dscp_set_dscp_queue

match dscp 3

Dell# show running-config policy-map
!
policy-map type qos match_dscp_set_dscp_queue
!
class match_dscp_set_dscp_queue

set dscp 30

set cos 6

set qos-group 6

Dell# show running-config interface ethernet1/1/1
!
interface ethernet1/1/1

no shutdown

switchport mode trunk

service-policy input type qos match_dscp_set_dscp_queue

The incoming traffic in port 1/1/1 is an IP traffic with VLAN 10 and dot1p 3 part of the VLAN header and DSCP value of 3 in the IP header. The Policy map match_dscp_set_dscp_queue is applied on the interface. This results in the following:

The Encapsulated traffic flowing out of Port 1/1/3 has DSCP value of 30 and flowing out of Queue 6. The traffic flowing out of port 1/1/2 will have DSCP value of 30 and flowing out of Queue 6 and do not have VLAN header since it is an untagged port.

Use Case 8: QoS Policy applied on Untagged access ports part of Virtual Networks

Create a Class Map to match the DSCP value in the incoming traffic and a Policy Map to set a new DSCP value of 30, dot1p value of 6 and the desired outgoing Queue number 6 and apply the same on the incoming untagged VxLAN access port.

Dell# show running-config class-map
!
class-map type qos untag_match_dscp_set_dot1p

match dscp 3

Dell# show running-config policy-map
!
policy-map type qos untag_match_dscp_set_dot1p
!
class untag_match_dscp_set_dot1p

set dscp 30

set cos 7

set qos-group 7

Dell# show running-config interface ethernet1/1/2
!
interface ethernet1/1/1

no shutdown

switchport mode trunk

service-policy input type qos untag_match_dscp_set_dot1p

The incoming traffic in port 1/1/2 is an IP traffic DSCP value of 3 in the IP header. The Policy map untag_match_dscp_set_dot1p is applied on the interface. This results in the following:

The Encapsulated traffic flowing out of Port 1/1/3 has DSCP value of 30 and flowing out of Queue 7.

The traffic flowing out of port 1/1/1 will have VLAN 10, dot1p priority 7 and DSCP value of 30 flowing out of Queue 7.

QoS in VxLAN Network Ports (Traffic from Network ports to Access ports)

Use Case 1: QoS Policy to match incoming DSCP and set new DSCP, dot1p and outgoing Queue

Create a Class Map to match the DSCP value in the incoming traffic on the Network port and a Policy Map to set a new DSCP value of 30 and the desired outgoing Queue number 6 and apply the same on the network port. The qos-group configured sets the outgoing dot1p priority in the egress traffic.

Dell# show running-config class-map
!
class-map type qos match_dscp_set_dscp_queue

match dscp 30

Dell# show running-config policy-map
!
policy-map type qos match_dscp_set_dscp_queue
!
class match_dscp_set_dscp_queue

set dscp 3

set cos 6

set qos-group 6

Dell# show running-config interface ethernet1/1/3
!
interface ethernet1/1/3

no shutdown

switchport mode trunk

service-policy input type qos match_dscp_set_dscp_queue

The incoming encapsulated traffic arriving in port 1/1/3 has a DSCP value of 30 in the Outer IP header. This DSCP value is matched in the Class Map. The Policy map match_dscp_set_dscp_queue is applied on the network port. This results in the following:

The traffic flowing out of Port 1/1/1 has DSCP value of 30, VLAN 10 and dot1p priority 6 in the packet and flows out of Queue 6.

The traffic flowing out of port 1/1/2 will have DSCP value of 3 flowing out of Queue 6. The traffic will not have any VLAN header as it is an untagged port. If port 1/1/2 is configured as a trunk port, the outgoing traffic will have the VLAN header with VLAN 20 and dot1p priority 6 in addition to the DSCP value of 6.

QoS in VTEPs if Network ports are L3 VLANs

In the previous sections, the Network ports on the VTEPs towards the Spine nodes are physical L3 uplinks. These network ports can also be L3 VLANs. If L3 VLANs are configured as network ports, the encapsulated packets will have the following and below actions can be performed.

  1. The configured VLAN in the encapsulated VxLAN outer header.
  2. The dot1p priority in the outer header can be modified using the Policy maps configured.

Similarly on the incoming packets on the network ports, the matching can be done based on the incoming dot1p priority and VLAN in addition to the DSCP value on the outer header of the encapsulated VxLAN packets.

QoS in Spine Node

The QoS policy maps can be created in the Spine nodes. When policy maps are applied on the Spine interfaces, the packet matching and action both happens on the outer header of the VxLAN encapsulated packets. The below classification and remarking can be configured on the Spine nodes.

  1. Match VLAN and set dot1p, set DSCP and set Queue.
  2. Match DSCP and set dot1p, set DSCP and set Queue.
  3. Match dot1p and set dot1p, set DSCP and set Queue.

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\