Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell SmartFabric OS10 User Guide Release 10.5.3

PDF

default interface

Resets an Ethernet or Fibre Channel interface to its default settings.

Syntax
default interface interface-type
Parameters
interface-type — Enter the interface type:
  • ethernet node/slot/port[:subport] — Resets an Ethernet interface to its default settings.
  • fibrechannel node/slot/port[:subport] — Resets a Fibre Channel interface to its default settings.
  • range ethernet node/slot/port:[subport]-node/slot/port[:subport] — Resets a range of Ethernet interfaces to their default settings.
Default
Not configured
Command mode
CONFIGURATION
Usage information
To remove the configuration from an Ethernet or Fibre Channel interface and reset the interface to its default settings, use the default interface command. By default:
  • An Ethernet interface is enabled using the no shutdown command; a Fibre Channel interface is disabled using the shutdown command.
  • An Ethernet interface is assigned to the default VLAN.
The default interface command removes all software settings and all L3, VLAN, and port-channel configurations on a physical interface. You must manually remove configured links to the interface from other software features; for example, if you configure an Ethernet interface as a discovery interface in a VLT domain. Enter multiple interfaces in a comma-separated string or a port range using the default interface range command.

There is no undo for this command. The no version of the command has no effect.

Example (Ethernet)
OS10# show running-configuration interface ethernet 1/1/15
 !
 interface ethernet1/1/15
 no shutdown
 no switchport
 ip address 101.1.2.2/30
 ipv6 address 2101:100:2:1::2/64
 ipv6 ospf 65535 area 0.0.0.0
 ipv6 ospf cost 10
 ip ospf 65535 area 0.0.0.0
 ip ospf cost 10

OS10# configure terminal

OS10(config)# default interface ethernet 1/1/15
 Proceed to cleanup the interface config? [confirm yes/no]:yes
 Mar 5 22:00:48 OS10 dn_l3_core_services[590]: Node.1-Unit.1:PRI:notice [os10:trap], %Dell EMC (OS10) %log-notice:IP_ADDRESS_DEL: IP Address delete is successful. IP 101.1.2.2/30 deleted successfully
 Mar 5 22:00:48 OS10 dn_l3_core_services[590]: Node.1-Unit.1:PRI:notice [os10:trap], %Dell EMC (OS10) %log-notice:IP_ADDRESS_DEL: IP Address delete is successful. IP 2101:100:2:1::2/64 deleted successfully
 
OS10(config)# end

OS10# show running-configuration interface ethernet 1/1/15
 !
 interface ethernet1/1/15
 no shutdown
 switchport access vlan 1
Example (Fibre channel)
OS10# show running-configuration interface fibrechannel 1/1/1
!
interface fibrechannel1/1/1
no shutdown
description fc-port

OS10(config)# default interface fibrechannel 1/1/1
Proceed to cleanup the interface config? [confirm yes/no]:y
!
OS10 # show running-configuration interface fibrechannel 1/1/1
interface fibrechannel1/1/1
shutdown
Example (Range of interfaces)
OS10(config)# interface range ethernet 1/1/1-1/1/4
 OS10(conf-range-eth1/1/1-1/1/4)# show configuration
 !
 interface ethernet1/1/1
 no shutdown
 no switchport
 ip address 192.21.43.1/31
 ipv6 address 2000:21:43::21:43:1/127
 !
 interface ethernet1/1/2
 no shutdown
 no switchport
 !
 interface ethernet1/1/3
 no shutdown
 no switchport
 ip address 192.28.43.1/31
 ipv6 address 2000:28:43::28:43:1/127
 !
 interface ethernet1/1/4
 no shutdown
 no switchport
 ip address 192.41.43.1/31
 ipv6 address 2000:41:43::41:43:1/127

OS10(conf-range-eth1/1/1-1/1/4)# exit
 
OS10(config)# default interface range ethernet 1/1/1,1/1/2-1/1/4

Proceed to cleanup interface range config? [confirm yes/no]:yes
 Mar 5 22:21:12 OS10 dn_l3_core_services[590]: Node.1-Unit.1:PRI:notice [os10:trap], %Dell EMC (OS10) %log-notice:IP_ADDRESS_DEL: IP Address delete is successful. IP 192.21.43.1/31 deleted successfully
 Mar 5 22:21:12 OS10 dn_l3_core_services[590]: Node.1-Unit.1:PRI:notice [os10:trap], %Dell EMC (OS10) %log-notice:IP_ADDRESS_DEL: IP Address delete is successful. IP 2000:21:43::21:43:1/127 deleted successfully
 Mar 5 22:21:12 OS10 dn_l3_core_services[590]: Node.1-Unit.1:PRI:notice [os10:trap], %Dell EMC (OS10) %log-notice:IP_ADDRESS_DEL: IP Address delete is successful. IP 192.28.43.1/31 deleted successfully
 Mar 5 22:21:12 OS10 dn_l3_core_services[590]: Node.1-Unit.1:PRI:notice [os10:trap], %Dell EMC (OS10) %log-notice:IP_ADDRESS_DEL: IP Address delete is successful. IP 2000:28:43::28:43:1/127 deleted successfully
 Mar 5 22:21:12 OS10 dn_l3_core_services[590]: Node.1-Unit.1:PRI:notice [os10:trap], %Dell EMC (OS10) %log-notice:IP_ADDRESS_DEL: IP Address delete is successful. IP 192.41.43.1/31 deleted successfully
 Mar 5 22:21:12 OS10 dn_l3_core_services[590]: Node.1-Unit.1:PRI:notice [os10:trap], %Dell EMC (OS10) %log-notice:IP_ADDRESS_DEL: IP Address delete is successful. IP 2000:41:43::41:43:1/127 deleted successfully
 Mar 5 22:21:12 OS10 dn_ifm[602]: Node.1-Unit.1:PRI:notice [os10:trap], %Dell EMC (OS10) %log-notice:IFM_OSTATE_UP: Interface operational state is up :vlan1
 
OS10(config)# interface range ethernet 1/1/1-1/1/4
OS10(conf-range-eth1/1/1-1/1/4)# show configuration
 !
 interface ethernet1/1/1
 no shutdown
 switchport access vlan 1
 !
 interface ethernet1/1/2
 no shutdown
 switchport access vlan 1
 !
 interface ethernet1/1/3
 no shutdown
 switchport access vlan 1
 !
 interface ethernet1/1/4
 no shutdown
 switchport access vlan 1

OS10(conf-range-eth1/1/1-1/1/4)#
Supported releases
10.4.0E(R1) or later

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\