Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell SmartFabric OS10 User Guide Release 10.5.3

PDF

QoS VXLAN examples

This section provides an overview of various QoS configurations in a VXLAN environment.

The following topology is used to explain various QoS configurations in a VXLAN environment:

qos-vxlan-examples

Topology Description

This topology consists of two VTEPs and a spine node to which the VTEP nodes are connected. The two VTEPs are as follows:

  • VTEP 1 – VLT VTEP consisting of a primary node and secondary node with VTEP IP as 31.1.1.1.
  • VTEP 2 – Standalone node with VTEP IP as 32.1.1.1.

Each VTEP consists of a VRF (VRF GREEN) with two VNs in the VRF. Each VN is mapped to a corresponding Port-VLAN combination in the VTEP. In case of VTEP1, hosts are connected to the corresponding VLAN through the VLT port-channel. In case of VTEP-2, hosts are directly connected.

The VRF GREEN consists of VNs in symmetric IRB mode of routing over an EVPN VRF-VNI of 4001. Each virtual network has the corresponding IP addresses with anycast IP addresses and the Port-VLAN (P, V) configurations part of the Virtual Network.

The connectivity between the VTEP nodes and spine node are direct physical Layer 3 links.

Supported configurations

This section describes various QoS-VXLAN configurations.

Virtual network configuration

Virtual Network is an L2 Bridge domain in the overlay network. Each virtual network is configured with the access ports that are part of the virtual network and the VxLAN Network Identifier (VNI).

VTEP-1-VLT-PRI# show running-configuration virtual-network
!
virtual-network 200
 member-interface port-channel1 vlan-tag 200
 vlti-vlan 200
 !
 vxlan-vni 200
!

IRB configurations

To enable Routing between virtual networks over a VxLAN domain, each virtual network needs to be configured with an IRB interface. This IRB interface consists of the IP address and the anycast addresses. These addresses correspond to the virtual-network and the VRF on which the virtual network is a part. Both IPv4 and IPv6 addresses are supported for virtual-network interfaces.

In addition to the IRB interface configurations, you must configure the same anycast MAC address globally in all VTEPs using the ip virtual-router mac-address command.

VTEP-1-VLT-PRI# show running-configuration | grep mac
!
ip virtual-router mac-address 00:11:22:33:44:55
!

VTEP-1-VLT-PRI# show running-configuration interface virtual-network 200
!
interface virtual-network200
 no shutdown
 ip vrf forwarding green
 ip address 20.1.1.1/24
 ip virtual-router address 20.1.1.32
 ipv6 address 20::1/64
 ipv6 virtual-router address 20::32

EVPN configurations

You must map each virtual network to an EVPN Instance (EVI). Both auto-evi and manual-evi are supported.

Auto EVI configuration automatically creates an EVI and maps it to the VNI and assigns the RD and RT automatically to each of the EVI.

In case of manual configuration, you must create an EVI and map the VNI and add RD and RT for each EVI manually.

VTEP-1-VLT-PRI# show running-configuration evpn
!
evpn
 auto-evi
!
VTEP-1-VLT-PRI# show evpn evi 200

EVI : 200, State : up
  Bridge-Domain       : Virtual-Network 200, VNI 200
  Route-Distinguisher : 1:31.1.1.1:200(auto)
  Route-Targets       : 0:65000:268435656(auto) both
  Inclusive Multicast : 32.1.1.1
  IRB                 : Enabled(green)

Symmetric IRB specific configurations

To enable symmetric IRB over a VRF, you must configure a router MAC address in each VTEP and the VRF has to be configured with its own VRF-VNI, RD and RT.

VTEP-1-VLT-PRI# show running-configuration evpn
!
evpn
 auto-evi
 router-mac 00:aa:aa:aa:aa:aa
 !
 vrf green
  vni 4001
  route-target auto
!
VTEP-1-VLT-PRI# show evpn vrf l3-vni

VRF : green, State : up
  L3-VNI              : 4001
  Route-Distinguisher : 1:31.1.1.1:4001(auto)
  Route-Targets       : 0:65000:268439457(auto) both
  Remote VTEP         :
        32.1.1.1
VTEP-1-VLT-PRI# show evpn router-mac

Local Router MAC : 00:aa:aa:aa:aa:aa

Remote-VTEP                              Router's-MAC
32.1.1.1                                 00:bb:bb:bb:bb:bb

VTEP-1-VLT-PRI#

QoS configurations

The below section describes the QoS configurations. The example considers to match a dot1p priority 3 from the incoming traffic and set a DSCP value of 5 for the mapped traffic.

VTEP 1 to VTEP2

VTEP-1 (VLT Primary)- ACCESS to Network - Match dot1p set Dscp

Create a class map and add a match rule to map dot1p priority 3.

VTEP-1-VLT-PRI(config)# class-map type qos CMAP1
VTEP-1-VLT-PRI(config-cmap-qos)# match cos 3

Create a Policy MAP to set DSCP value of 5 for the traffic matched by class map CMAP1.

VTEP-1-VLT-PRI(config)# policy-map type qos PMAP1
VTEP-1-VLT-PRI(config-pmap-qos)# class CMAP1
VTEP-1-VLT-PRI(config-pmap-c-qos)# set dscp 5

Apply the policy map to the ingress interface.

VTEP-1-VLT-PRI(config)# interface ethernet 1/1/25:1
VTEP-1-VLT-PRI(conf-if-eth1/1/25:1)# service-policy input type qos PMAP1

Verify the configuration.

VTEP-1-VLT-PRI# show running-configuration class-map 
!
class-map type qos CMAP1
 match cos 3

VTEP-1-VLT-PRI# show running-configuration policy-map 
!
policy-map type qos PMAP1
 !
 class CMAP1
  set dscp 5

VTEP-1-VLT-PRI# show running-configuration interface ethernet 1/1/25:1
!
interface ethernet1/1/25:1
 no shutdown
 channel-group 1 mode active
 flowcontrol receive on
 mtu 9216
 service-policy input type qos PMAP1

VTEP-1 (VLT Secondary)- ACCESS to Network - Match dot1p set Dscp

You must also configure VLT Secondary node with the class map, policy map and apply it over the access interface.

Create a class map and add a match rule to map dot1p priority 3.

VTEP-1-VLT-SEC(config)# class-map type qos CMAP1
VTEP-1-VLT-SEC(config-cmap-qos)# match cos 3

Create a policy map to set DSCP value of 5 for the traffic matched by class map CMAP1.

VTEP-1-VLT-SEC(config)# policy-map type qos PMAP1
VTEP-1-VLT-SEC(config-pmap-qos)# class CMAP1
VTEP-1-VLT-SEC(config-pmap-c-qos)# set dscp 5
VTEP-1-VLT-SECI(config-pmap-c-qos)#

Apply the policy map to the ingress interface.

VTEP-1-VLT-SEC(config)# interface ethernet 1/1/25:1
VTEP-1-VLT-SEC(conf-if-eth1/1/25:1)# service-policy input type qos PMAP1
VTEP-1-VLT-SEC(conf-if-eth1/1/25:1)#

Verify the configurations.

VTEP-1-VLT-SEC# show running-configuration class-map 
!
class-map type qos CMAP1
 match cos 3

VTEP-1-VLT-SEC# show running-configuration policy-map 
!
policy-map type qos PMAP1
 !
 class CMAP1
  set dscp 5

VTEP-1-VLT-SEC# show running-configuration interface ethernet 1/1/25
!
interface ethernet1/1/25
 no shutdown
 channel-group 1 mode active
 flowcontrol receive on
 mtu 9216
 service-policy input type qos PMAP1

VTEP-2 Network Port to Access Port - Match DSCP Set dot1p

In VTEP 2, the incoming packet at the network port will have the DSCP configured in the VTEP-1. This example shows to set a dot1p priority for a traffic with a match dscp value.

Create a Class MAP and add a match rule to map DSCP value of 5.

VTEP-2(config)# class-map type qos CMAP1
VTEP-2(config-cmap-qos)# match ip dscp 5

Create a policy map to set dot1p value of 3 for the traffic matched by Class Map CMAP1.

VTEP-2(config)# policy-map type qos PMAP1
VTEP-2(config-pmap-qos)# class CMAP1
VTEP-2(config-pmap-c-qos)# set cos 3
VTEP-2(config-pmap-c-qos)# set qos-group 3
VTEP-2(config-pmap-c-qos)#

Apply the policy map to the network port of VTEP-2 so that it matches the incoming traffic from Spine node with the class map CMAP1 and apply the Policy MAP PMAP1 to the matched traffic.

VTEP-2(config)# interface ethernet 1/1/1:1
VTEP-2(conf-if-eth1/1/1:1)# service-policy input type qos PMAP1
VTEP-2(conf-if-eth1/1/1:1)#

Verify the configurations.

VTEP-2# show running-configuration class-map 
!
class-map type qos CMAP1
 match ip dscp 5

VTEP-2# show running-configuration policy-map 
!
policy-map type qos PMAP1
 !
 class CMAP1
  set cos 3
  set qos-group 3

VTEP-2# show running-configuration interface ethernet 1/1/1:1
!
interface ethernet1/1/1:1
 no shutdown
 no switchport
 ip address 11.1.1.4/31
 flowcontrol receive on
 mtu 9216
service-policy input type qos PMAP1

VTEP 2 to VTEP1

In the reverse direction traffic from VTEP-2 to VTEP-1, the below example matches one DSCP value and sets another DSCP value to the traffic in the Ingress VTEP VTEP-2 and then matches the incoming DSCP value and set a dot1p value in the Egress VTEP VTEP-1.

VTEP-2 Access to Network - Match DSCP Set DSCP

VTEP-2(config)# do show running-configuration class-map
!
class-map type qos CMAP2
 match ip dscp 5


VTEP-2(config)# do show running-configuration policy-map
!
policy-map type qos PMAP2
 !
 class CMAP2
  set dscp 7


VTEP-2(config)# do show running-configuration interface ethernet 1/1/3:1
!
interface ethernet1/1/3:1
 no shutdown
 switchport mode trunk
 switchport trunk allowed vlan 200
 mtu 9216
 flowcontrol receive off
 service-policy input type qos PMAP2
VTEP-2(config)#

VTEP-1 (VLT Secondary & Primary) Network to Access - Match dscp set dot1p

The below configuration matches a DSCP value and set a dot1p value. The configurations are common to both the devices in VLT.

VTEP-1-VLT-PRI(conf)# do show running-config class-map
!
class-map type qos CMAP2
 match ip dscp 7

VTEP-1-VLT-PRI(conf)# do show running-config policy-map
!
policy-map type qos PMAP2
!
 class CMAP2
  set cos 5
  set qos-group 5

VTEP-1-VLT-PRI(conf)#do show running-config ethernet 1/1/1:1
!
interface ethernet 1/1/1:1
 no shutdown
 no switchport
 ip address 11.1.1.0/31
 mtu 9216
 flowcontrol receive off
 service-policy input type qos PMAP2

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\