メイン コンテンツに進む
  • すばやく簡単にご注文が可能
  • 注文内容の表示、配送状況をトラック
  • 会員限定の特典や割引のご利用
  • 製品リストの作成とアクセスが可能
  • 「Company Administration(会社情報の管理)」では、お使いのDell EMCのサイトや製品、製品レベルでのコンタクト先に関する情報を管理できます。

Dell EMC SmartFabric OS10 User Guide Release 10.5.0

PDF

PBR and VLT

When you configure PBR in a VLT setup, configure the same PBR rules on both VLT peers.

In the following example, traffic originates from A and is destined to B. The traffic is redirected to C using a PBR rule through the VLT port channel. When the VLT port channel interface goes down, the traffic still reaches C through VLTi.

DHCP snooping Layer 3 VLT

SW1

VLAN configuration

  • Create a VLAN and assign an IP address to it which acts as the gateway for the hosts in the VM.

    OS10# configure terminal
    OS10(config)# interface vlan 100
    OS10(conf-if-vl-100)# no shutdown
    OS10(conf-if-vl-100)# ip address 10.1.1.1/24
    OS10(conf-if-vl-100)# exit
    
  • Create another VLAN, and assign an IP address to it.

    OS10# configure terminal
    OS10(config)# interface vlan 200
    OS10(conf-if-vl-200)# no shutdown
    OS10(conf-if-vl-200)# ip address 10.2.1.1/24
    OS10(conf-if-vl-200)# exit
    

VLT configuration

  1. Create a VLT domain, and configure VLTi.

    OS10(config)# interface range ethernet 1/1/4-1/1/5
    OS10(conf-range-eth1/1/4-1/1/5)# no switchport
    OS10(conf-range-eth1/1/4-1/1/5)# exit
    OS10(config)# vlt-domain 1
    OS10(conf-vlt-1)# discovery-interface ethernet 1/1/4-1/1/5
  2. Configure a VLT MAC address.

    OS10(conf-vlt-1)# vlt-mac 12:5e:23:2d:76:3e
  3. Specify the management IP address of the VLT peer as a backup link.

    OS10(conf-vlt-1)# backup destination 10.10.10.2
    
  4. Configure VLT port channels.

    SW1-to-VM VLT port channel configuration

    OS10(config)# interface port-channel 10
    OS10(conf-if-po-10)# description SW1ToVM
    OS10(conf-if-po-10)# vlt-port-channel 10
    OS10(conf-if-po-10)# switchport mode trunk
    OS10(conf-if-po-10)# switchport trunk allowed vlan 100,200
    OS10(conf-if-po-10)# exit
    OS10(config)# interface ethernet 1/1/2-1/1/3
    OS10(conf-if-eth1/1/2-1/1/3)# no shutdown
    OS10(conf-if-eth1/1/2-1/1/3)# channel-group 10
    

    SW1-to-server configuration

    OS10(config)# interface port-channel 20
    OS10(conf-if-po-20)# description SW1ToServer
    OS10(conf-if-po-20)# vlt-port-channel 20
    OS10(conf-if-po-20)# switchport mode trunk
    OS10(conf-if-po-20)# switchport trunk allowed vlan 100,200
    OS10(conf-if-po-20)# exit
    OS10(config)# interface ethernet 1/1/1,1/1/6
    OS10(conf-if-eth1/1/1,1/1/6)# no shutdown
    OS10(conf-if-eth1/1/1,1/1/6)# channel-group 20
    

(Optional) Peer routing configuration

  • Configure peer routing.

    OS10(config)# vlt-domain 1
    OS10(conf-vlt-1)# peer-routing

PBR configuration

Apply the policy on the traffic ingress interface and the VLTi interfaces of both VLT peers.

OS10(config)# ip access-list PBR-A2C
OS10(conf-ipv4-acl)# permit ip 10.10.10.0/24 any
OS10(conf-route-map)# route-map Map1
OS10(conf-route-map)# match ip address PBR-A2C
OS10(conf-route-map)# set ip next-hop 10.10.20.10
OS10(conf-route-map)# exit
OS10(config)# interface ethernet 1/1/4-1/1/6
OS10(conf-if-eth1/1/4-1/1/6)# ip policy route-map Map1

SW2

VLAN configuration

  • Create a VLAN and assign an IP address to it which acts as the gateway for the hosts in the VM.

    OS10# configure terminal
    OS10(config)# interface vlan 100
    OS10(conf-if-vl-100)# no shutdown
    OS10(conf-if-vl-100)# ip address
    OS10(conf-if-vl-100)# ip address 10.1.1.2/24
    OS10(conf-if-vl-100)# exit
    
  • Create another VLAN, and assign an IP address to it.

    OS10# configure terminal
    OS10(config)# interface vlan 200
    OS10(conf-if-vl-200)# no shutdown
    OS10(conf-if-vl-200)# ip address
    OS10(conf-if-vl-200)# ip address 10.2.1.3/24
    OS10(conf-if-vl-200)# exit
    

VLT configuration

  1. Create a VLT domain, and configure VLTi.

    OS10(config)# interface range ethernet 1/1/4-1/1/5
    OS10(conf-range-eth1/1/4-1/1/5)# no switchport
    OS10(conf-range-eth1/1/4-1/1/5)# exit
    OS10(config)# vlt-domain 1
    OS10(conf-vlt-1)# discovery-interface ethernet 1/1/4-1/1/5
  2. Configure a VLT MAC address.

    OS10(conf-vlt-1)# vlt-mac 12:5e:23:f4:23:54
  3. Specify the management IP address of the VLT peer as a backup link.

    OS10(conf-vlt-1)# backup destination 10.10.10.1
    
  4. Configure VLT port channels.

    SW2-to-VM VLT port channel configuration

    OS10(config)# interface port-channel 10
    OS10(conf-if-po-10)# description SW2ToVM
    OS10(conf-if-po-10)# vlt-port-channel 10
    OS10(conf-if-po-10)# switchport mode trunk
    OS10(conf-if-po-10)# switchport trunk allowed vlan 100,200
    OS10(conf-if-po-10)# exit
    OS10(config)# interface ethernet 1/1/2-1/1/3
    OS10(conf-if-eth1/1/2-1/1/3)# no shutdown
    OS10(conf-if-eth1/1/2-1/1/3)# channel-group 10
    

( Optional) Peer routing configuration

  • Configure peer routing.

    OS10(config)# vlt-domain 1
    OS10(conf-vlt-1)# peer-routing

PBR configuration

Apply the policy on the VLTi interfaces of both VLT peers.

OS10(config)# ip access-list PBR-A2C
OS10(conf-ipv4-acl)# permit ip 10.10.10.0/24 any
OS10(conf-route-map)# route-map Map1
OS10(conf-route-map)# match ip address PBR-A2C
OS10(conf-route-map)# set ip next-hop 10.10.20.10
OS10(conf-route-map)# exit
OS10(config)# interface ethernet 1/1/4-1/1/6
OS10(conf-if-eth1/1/4-1/1/6)# ip policy route-map Map1

このコンテンツを評価する

正確
有益
分かりやすい
この記事は役に立ちましたか?
0/3000 characters
  1~5個の星の数で評価してください。
  1~5個の星の数で評価してください。
  1~5個の星の数で評価してください。
  この記事は役に立ちましたか?
  コメントでは、以下の特殊文字は利用できません: <>()\